HV_NETVSC(4FREEBSD) - man page online | special files
Hyper-V Network Virtual Service Consumer.
September 10, 2013
HYPER-V(4) BSD Kernel Interfaces Manual HYPER-V(4)
NAMEhv_netvsc — Hyper-V Network Virtual Service Consumer
SYNOPSISTo compile this driver into the kernel, place the following lines in the system kernel con‐ figuration file: device hyperv
DESCRIPTIONThe hv_netvsc driver implements the virtual network device for FreeBSD guest partitions run‐ ning on Hyper-V. FreeBSD guest partitions running on Hyper-V do not have direct access to network devices attached to the Hyper-V server. Although a FreeBSD guest can access network devices using Hyper-V's full emulation mode, the performance in this mode tends to be unsat‐ isfactory. To counter the above issues, the hv_netvsc driver implements a network Virtual Service Con‐ sumer (VSC) that relays network requests from the guest partition to the network Virtual Service Provider (VSP) hosted in the root partition using the high performance data exchange infrastructure provided by hv_vmbus(4) driver. The VSP in the root partition then forwards the network related requests to the physical network card.
SEE ALSOhv_vmbus(4), hv_utils(4), hv_storvsc(4), hv_ata_pci_disengage(4)
HISTORYSupport for hv_netvsc first appeared in FreeBSD 10.0. The driver was developed through a joint effort between Citrix Incorporated, Microsoft Corporation, and Network Appliance Incorporated.
BSD September 10, 2013 BSD
AUTHORSFreeBSD support for hv_netvsc was first added by Microsoft BSD Integration Services Team <@microsoft.com>.
|This manual||Reference||Other manuals|
|hv_netvsc(4freebsd)||referred by||hv_ata_pci_disengage(4freebsd) | hv_kvp(4freebsd) | hv_storvsc(4freebsd) | hv_utils(4freebsd) | hv_vmbus(4freebsd)|
|refer to||hv_ata_pci_disengage(4freebsd) | hv_storvsc(4freebsd) | hv_utils(4freebsd) | hv_vmbus(4freebsd)|