HV_UTILS(4FREEBSD) - man page online | special files
Hyper-V Utilities Driver.
September 10, 2013
HYPER-V(4) BSD Kernel Interfaces Manual HYPER-V(4)
NAMEhv_utils — Hyper-V Utilities Driver
SYNOPSISTo compile this driver into the kernel, place the following lines in the system kernel con‐ figuration file: device hyperv
DESCRIPTIONThe hv_utils driver provides time keeping, shutdown and heartbeat functionality for FreeBSD guest partitions running on Hyper-V. Hyper-V is a hypervisor-based virtualization technol‐ ogy from Microsoft. The hv_utils driver is one of the core drivers required to be present in guest partitions running on Hyper-V. This driver provides the following functionalities to guest partitions: (a) Time Keeping: The clock inside the guest partition will remain accurate by synchronizing to the clock on the virtualization server via Timesync service, and with the help of the pluggable time source device. (b) Integrated shutdown: Guest partitions running FreeBSD can be shut down from Hyper-V Man‐ ager console by using the "Shut down" command. (c) Heartbeat: This feature allows the virtualization server to detect whether the guest partition is running and responsive.
SEE ALSOhv_vmbus(4), hv_netvsc(4), hv_storvsc(4), hv_ata_pci_disengage(4)
HISTORYSupport for hv_utils first appeared in FreeBSD 10.0. The driver was developed through a joint effort between Citrix Incorporated, Microsoft Corporation, and Network Appliance Incorporated.
BSD September 10, 2013 BSD
AUTHORSFreeBSD support for hv_utils was first added by Microsoft BSD Integration Services Team <@microsoft.com>.
|This manual||Reference||Other manuals|
|hv_utils(4freebsd)||referred by||hv_ata_pci_disengage(4freebsd) | hv_kvp(4freebsd) | hv_netvsc(4freebsd) | hv_storvsc(4freebsd) | hv_vmbus(4freebsd)|
|refer to||hv_ata_pci_disengage(4freebsd) | hv_netvsc(4freebsd) | hv_storvsc(4freebsd) | hv_vmbus(4freebsd)|