ICHWD(4FREEBSD) - Linux man page online | Special files
Device driver for the Intel ICH watchdog interrupt timer.
August 20, 2008
ICHWD(4) BSD Kernel Interfaces Manual ICHWD(4)
BSD August 20, 2008 BSD
NAMEichwd — device driver for the Intel ICH watchdog interrupt timer
SYNOPSISTo compile this driver into the kernel, place the following line in your kernel configura‐ tion file: device ichwd Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): ichwd_load="YES"
DESCRIPTIONThe ichwd driver provides watchdog(4) support for the watchdog interrupt timer present on all Intel ICH motherboard chipsets. The ICH WDT counts down in ticks of approximately 0.6 seconds; the exact value depends on hardware quality and environmental factors. Supported watchdog intervals range from 2 to 63 ticks. Note that on some ICH-based systems, the WDT may be present but disabled, either in hardware or by the BIOS. The ichwd driver attempts to detect this condition and will refuse to attach if it believes the WDT is disabled.
SEE ALSOwatchdog(4), watchdog(8), watchdogd(8), watchdog(9) Using the Intel ICH Family Watchdog Timer (WDT), Intel Application Note AP-725, Document Number 292273-001.
HISTORYThe ichwd driver first appeared in FreeBSD 5.3.
AUTHORSThe ichwd driver was written by Wm. Daryl Hawkins <@tamu.edu> of Texas A&M Univer‐ sity and Dag-Erling Smørgrav <@FreeBSD.org>. This manual page was written by Dag-Erling Smørgrav <@FreeBSD.org>.
|This manual||Reference||Other manuals|
|refer to||watchdog(4freebsd) | watchdog(8) | watchdog(9freebsd)|