IE(4FREEBSD) - Linux man page online | Special files
Ethernet device driver.
July 8, 2017
IE(4) BSD/i386 Kernel Interfaces Manual IE(4)
BSD July 8, 2017 BSD
NAMEie — Ethernet device driver
SYNOPSISTo compile this driver into the kernel, place the following line in your kernel configura‐ tion file: device ie Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): if_ie_load="YES" In /boot/device.hints: hint.ie.0.at="isa" hint.ie.0.port="0x300" hint.ie.0.irq="5" hint.ie.0.maddr="0xd0000"
DEPRECATION NOTICEThe ie driver will be removed in FreeBSD 12.0.
HARDWAREThe ie driver provides supports the following 8 and 16bit ISA Ethernet cards that are based on the Intel i82586 chip: · 3COM 3C507 · AT&T EN100 · AT&T Starlan 10 · AT&T Starlan Fiber · Intel EtherExpress 16 · RACAL Interlan NI5210
DIAGNOSTICSie%d: unknown board type code %d An i82586 chip was found, but the driver was unable to determine the actual board type during the probe. ie%d: kernel configured maddr %x doesn't match board configured maddr %x The device probe detected a different maddr than the one specified in the kernel configuration file. ie%d: can't find shared memory The device probe could not access the shared memory to determine its size. ie%d: kernel configured msize %d doesn't match board configured msize %d The device probe found a different size for the shared memory than the one specified in the kernel configura‐ tion file. ie%d: kernel configured irq %d doesn't match board configured irq %d The device probe detected that the board is configured for a different interrupt than the one specified in the kernel configuration file. ie%d: reset The Intel i82586 had to be reset by the driver. ie%d: transceiver problem The driver has detected a problem with the Ethernet transceiver. This is usually due to a loose or broken transceiver cable when using an external trans‐ ceiver. When you experience this problem with an on-card transceiver your card may be incorrectly jumpered for to use an external transceiver. Worst case your on-board trans‐ ceiver may be broken. ie%d: TDR detected an open %d clocks away The driver detected an open circuit in the Ether‐ net cable. Check your coax cable and terminator resistors. ie%d: TDR detected a short %d clocks away The driver detected a short circuit in the Ether‐ net cable. Check your coax cable and terminator resistors. ie%d: TDR returned unknown status %x The driver got an unknown status from the card during the Ethernet cable test. ie%d: multicast address setup command failed The card could not be put into multicast mode. ie%d: configure command failed The card refused to respond correctly during configuration. ie%d: individual address setup command failed The programming of the Ethernet (MAC) address failed.
SEE ALSOarp(4), netintro(4), ng_ether(4), ifconfig(8)
AUTHORSThe ie device driver was written by Garrett A. Wollman, based on code by William F. Jolitz and Lawrence Berkeley Laboratories. 3C507 support was written by Charles M. Hannum. This manual page was written by Wilko C. Bulte.
CAVEATSThe Racal Interlan NI5210 comes in variants with 8 and 16 kbytes of shared memory. It is strongly advisable to use the 16 kbyte variant. You can upgrade your 8 kbyte card to 16 kbyte by adding an additional RAM chip.
|This manual||Reference||Other manuals|
|ie(4freebsd)||referred by||ep(4freebsd) | if_sn(4freebsd) | sn(4freebsd)|
|refer to||arp(4freebsd) | ifconfig(8) | netintro(4freebsd) | ng_ether(4freebsd)|