IF_SN(4FREEBSD) - Linux man page online | Special files
Ethernet driver for SMC91Cxx based cards.
July 16, 2005
SN(4) BSD Kernel Interfaces Manual SN(4)
BSD July 16, 2005 BSD
NAMEsn — Ethernet driver for SMC91Cxx based cards
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configura‐ tion file: device sn Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): if_sn_load="YES"
DESCRIPTIONThe sn device driver supports SMC91Cxx based ISA and PCMCIA cards.
HARDWAREThe sn driver supports SMC91Cxx based ISA and PCMCIA cards including: · 3Com Megahertz X-Jack Ethernet PC Card XJ10BT, XJ10BC · 3Com Megahertz XJEM and CCEM series: CCEM3288C, CCEM3288T, CCEM3336, CEM3336C, CCEM3336T, XJEM1144C, XJEM1144T, XJEM3288C, XJEM3288T, XJEM3336 · Farallon EtherMac PC Card 595a · Motorola Mariner Ethernet/Modem PC Card · Ositech Seven of Diamonds Ethernet PC Card · Ositech Jack of Hearts Ethernet/Modem PC Card · Psion Gold Card Netglobal Ethernet PC Card · Psion Gold Card Netglobal 10/100 Fast Ethernet PC Card · Psion Gold Card Netglobal 56k+10Mb Ethernet PC Card · SMC EZEther PC Card (8020BT) · SMC EZEther PC Card (8020T) The sn driver supports the SMC 91C90, SMC 91C92, SMC 91C94, SMC 91C95, SMC 91C96, SMC91C100 and SMC 91C100FD chips from SMC. The Farallon EtherWave and EtherMac card came in two varieties. The ep(4) driver supports the 595 and 895 cards. These cards have the blue arrow on the front along with a 3Com logo. The Farallon 595a cards, which have a red arrow on the front, are also called EtherWave and EtherMac. They are supported by the sn driver.
SEE ALSOed(4), ep(4), ie(4), intro(4), ng_ether(4), vx(4), ifconfig(8)
HISTORYThe sn device driver appeared in FreeBSD 4.0.
|This manual||Reference||Other manuals|
|refer to||ed(4freebsd) | ep(4freebsd) | ie(4freebsd) | ifconfig(8) | intro(4) | ng_ether(4freebsd) | sn(4freebsd) | vx(4freebsd)|