IF_AXE(4FREEBSD) - Linux man page online | Special files
ASIX Electronics AX88x7x/760 USB Ethernet driver.
November 24, 2015
AXE(4) BSD Kernel Interfaces Manual AXE(4)
BSD November 24, 2015 BSD
NAMEaxe — ASIX Electronics AX88x7x/760 USB Ethernet driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configura‐ tion file: device ehci device uhci device ohci device usb device miibus device uether device axe Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): if_axe_load="YES"
DESCRIPTIONThe axe driver provides support for USB Ethernet adapters based on the ASIX Electronics AX88172, AX88178, AX88772, AX88772A, AX88772B and AX88760 USB 2.0 chipsets. The AX88172, AX88772, AX88772A, AX88772B and AX88760 contain a 10/100 Ethernet MAC with MII interface and are designed to work with both Ethernet and HomePNA transceivers. The AX88178 has a 10/100/1000 Ethernet MAC with GMII/RGMII interface for interfacing with Gigabit Ether‐ net PHY. These devices will operate with both USB 1.x and USB 2.0 controllers, however performance with 1.x controllers will be limited since the USB 1.x standard specifies a maximum transfer speed of 12Mbps. Users with USB 1.x controllers should therefore not expect to actually achieve 100Mbps speeds with these devices. All chipsets support a 64-bit multicast hash table, single perfect filter entry for the sta‐ tion address, all-multicast mode and promiscuous mode. Packets are received and transmitted over separate USB bulk transfer endpoints. The axe driver supports the following media types: autoselect Enable autoselection of the media type and options. The user can manually override the autoselected mode by adding media options to rc.conf(5). 10baseT/UTP Set 10Mbps operation. The ifconfig(8) mediaopt option can also be used to select either full-duplex or half-duplex modes. 100baseTX Set 100Mbps (Fast Ethernet) operation. The ifconfig(8) mediaopt option can also be used to select either full-duplex or half-duplex modes. 1000baseT Set 1000Mbps (Gigabit Ethernet) operation (AX88178 only). The ifconfig(8) mediaopt option can also be used to select either full-duplex or half-duplex modes. The axe driver supports the following media options: full-duplex Force full duplex operation. half-duplex Force half duplex operation. For more information on configuring this device, see ifconfig(8).
HARDWAREThe axe driver supports ASIX Electronics AX88172/AX88178/AX88772/AX88772A/AX88772B/AX88760 based USB Ethernet adapters including: AX88172: · AboCom UF200 · Acer Communications EP1427X2 · ASIX AX88172 · ATen UC210T · Billionton SnapPort · Billionton USB2AR · Buffalo (Melco Inc.) LUA-U2-KTX · Corega USB2_TX · D-Link DUBE100 · Goodway GWUSB2E · JVC MP_PRX1 · LinkSys USB200M · Netgear FA120 · Sitecom LN-029 · System TALKS Inc. SGC-X2UL AX88178: · ASIX AX88178 · Belkin F5D5055 · Logitec LAN-GTJ/U2A · Buffalo (Melco Inc.) LUA3-U2-AGT · Planex Communications GU1000T · Sitecom Europe LN-028 AX88772: · ASIX AX88772 · Buffalo (Melco Inc.) LUA3-U2-ATX · D-Link DUBE100B1 · Planex UE-200TX-G · Planex UE-200TX-G2 AX88772A: · ASIX AX88772A · Cisco-Linksys USB200Mv2 AX88772B: · ASIX AX88772B · Lenovo USB 2.0 Ethernet AX88760: · ASIX AX88760
DIAGNOSTICSaxe%d: watchdog timeout A packet was queued for transmission and a transmit command was issued, however the device failed to acknowledge the transmission before a timeout expired. axe%d: no memory for rx list The driver failed to allocate an mbuf for the receiver ring.
SEE ALSOaltq(4), arp(4), miibus(4), netintro(4), ng_ether(4), rgephy(4), vlan(4), ifconfig(8) ASIX AX88x7x and AX88760 data sheets, http://www.asix.com.tw.
HISTORYThe axe device driver first appeared in FreeBSD 5.0.
AUTHORSThe axe driver was written by Bill Paul <@windriver.com>.
|This manual||Reference||Other manuals|
|refer to||arp(4freebsd) | axe(4freebsd) | ifconfig(8) | miibus(4freebsd) | netintro(4freebsd) | ng_ether(4freebsd) | rgephy(4freebsd) | vlan(4freebsd)|