RGEPHY(4FREEBSD) - man page online | special files
RealTek RTL8168/8169/8110/8211 series 10/100/1000 Gigabit Ethernet PHY driver.
January 16, 2011
RGEPHY(4) BSD Kernel Interfaces Manual RGEPHY(4)
NAMErgephy — RealTek RTL8168/8169/8110/8211 series 10/100/1000 Gigabit Ethernet PHY driver
SYNOPSISTo compile all available PHY drivers into the kernel, place the following line in your ker‐ nel configuration file: device miibus Alternatively, to selectively compile this driver into the kernel, place the following lines in your kernel configuration file instead: device mii device rgephy
DESCRIPTIONThe rgephy driver supports the RealTek RTL8168, RTL8169, RTL8110 and RTL8211 series inte‐ grated 10/100/1000 Gigabit Ethernet PHYs. In order to get a list of media types and options supported by a specific instance of the rgephy driver, run ifconfig -m on the instance of its parent MAC driver. Additionally, the rgephy driver supports the following special media option: flag0 When manually setting media type and options via ifconfig(8), the rgephy driver by default also triggers an autonegotiation advertising the selected media. This is done in order to work around hardware issues in certain scenarios. It is believed that this behavior does not cause harm in general but in fact can have an adverse effect in edge cases. In order to manually set the media type and options without also triggering an autonegotiation, the rgephy driver allows to turn this behavior off via the flag0 media option. Note that this special media option will not show up in the output of ifconfig(8), even when set.
EXAMPLESManually set 100BASE-TX full-duplex without also triggering an autonegotiation: ifconfig re0 media 100baseTX mediaopt full-duplex,flag0
BSD January 16, 2011 BSD
SEE ALSOintro(4), miibus(4), ifconfig(8)
|This manual||Reference||Other manuals|
|rgephy(4freebsd)||referred by||axe(4freebsd) | axge(4freebsd) | if_axe(4freebsd) | if_nfe(4freebsd) | if_nve(4freebsd) | if_re(4freebsd) | if_sge(4freebsd) | miibus(4freebsd) | nfe(4freebsd) | nve(4freebsd) | re(4freebsd) | sge(4freebsd)|
|refer to||ifconfig(8) | intro(4) | miibus(4freebsd)|