IF_FWIP(4FREEBSD) - Linux man page online | Special files
IP over FireWire driver.
July 16, 2005
FWIP(4) BSD Kernel Interfaces Manual FWIP(4)
BSD July 16, 2005 BSD
NAMEfwip — IP over FireWire driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configura‐ tion file: device firewire device fwip Alternatively, to load the driver as a module at boot time, place the following lines in loader.conf(5): firewire_load="YES" if_fwip_load="YES"
DESCRIPTIONThe fwip driver provides standard IP over FireWire (IEEE 1394) based on the protocols described in RFC 2734 and RFC 3146. The firewire(4) and fwohci(4) drivers must be configured in the kernel as well. This driver supports polling(4) as well if it is compiled with the DEVICE_POLLING option.
SEE ALSOarp(4), firewire(4), fwe(4), fwohci(4), netintro(4), polling(4), ifconfig(8), kldload(8), sysctl(8)
HISTORYThe fwip device driver first appeared in FreeBSD 5.3.
AUTHORSThe fwip driver and this manual page were written by Doug Rabson, based on earlier work by Hidetoshi Shimokawa.
BUGSThis driver currently does not support the MCAP protocol for multicast IP over FireWire. Multicast packets are treated as broadcast packets which is sufficient for most trivial uses of multicast.
|This manual||Reference||Other manuals|
|refer to||arp(4freebsd) | firewire(4freebsd) | fwe(4freebsd) | fwip(4freebsd) | fwohci(4freebsd) | ifconfig(8) | netintro(4freebsd) | polling(4freebsd) | sysctl(8)|