FWE(4FREEBSD) - Linux man page online | Special files
Ethernet emulation driver for FireWire.
July 16, 2005
FWE(4) BSD Kernel Interfaces Manual FWE(4)
BSD July 16, 2005 BSD
NAMEfwe — Ethernet emulation driver for FireWire
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configura‐ tion file: device firewire device fwe Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): if_fwe_load="YES"
DESCRIPTIONThe fwe driver provides non-standard Ethernet emulation over FireWire (IEEE 1394). firewire(4) and fwohci(4) must be configured in the kernel as well. This driver exploits asynchronous stream over IEEE 1394 to carry Ethernet frames. The stream channel can be specified by the hw.firewire.fwe.stream_ch sysctl(8). This driver supports polling(4) as well if it is compiled with the DEVICE_POLLING option.
SEE ALSOarp(4), firewire(4), fwip(4), fwohci(4), netintro(4), ng_ether(4), polling(4), ifconfig(8), kldload(8), sysctl(8)
HISTORYThe fwe device driver first appeared in FreeBSD 5.0.
AUTHORSThe fwe driver and this manual page were written by Hidetoshi Shimokawa.
BUGSThis driver emulates Ethernet in a very adhoc way and it does not reserve a stream channel using an isochronous manager. Note that this driver uses a protocol which is very different from RFC 2734 (IPv4 over IEEE 1394).
|This manual||Reference||Other manuals|
|fwe(4freebsd)||referred by||firewire(4freebsd) | fwip(4freebsd) | fwohci(4freebsd) | ieee1394(4freebsd) | if_fwe(4freebsd) | if_fwip(4freebsd) | if_vlan(4freebsd) | polling(4freebsd) | vlan(4freebsd)|
|refer to||arp(4freebsd) | firewire(4freebsd) | fwip(4freebsd) | fwohci(4freebsd) | ifconfig(8) | netintro(4freebsd) | ng_ether(4freebsd) | polling(4freebsd) | sysctl(8)|