IF_UPGT(4FREEBSD) - Linux man page online | Special files
Conexant/Intersil PrismGT SoftMAC USB IEEE 802.11b/g wireless network device.
UPGT(4) BSD Kernel Interfaces Manual UPGT(4)
BSD April 17, 2008 BSD
NAMEupgt — Conexant/Intersil PrismGT SoftMAC USB IEEE 802.11b/g wireless network device
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configura‐ tion file: device ehci device uhci device ohci device usb device upgt device wlan Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): if_upgt_load="YES"
DESCRIPTIONThe upgt driver supports the USB 2.0 Conexant/Intersil PrismGT series wireless adapters based on the GW3887 chipset. These are the modes the upgt driver can operate in: BSS mode Also known as infrastructure mode, this is used when associating with an access point, through which all traffic passes. This mode is the default. monitor mode In this mode the driver is able to receive packets without associating with an access point. This disables the internal receive filter and enables the card to capture packets from networks which it wouldn't normally have access to, or to scan for access points. upgt supports software WEP. Wired Equivalent Privacy (WEP) is the de facto encryption stan‐ dard for wireless networks. It can be typically configured in one of three modes: no encryption; 40-bit encryption; or 104-bit encryption. Unfortunately, due to serious weak‐ nesses in WEP protocol it is strongly recommended that it not be used as the sole mechanism to secure wireless communication. WEP is not enabled by default. The upgt driver can be configured at runtime with ifconfig(8).
FILESThis driver requires the upgtfw firmware to be installed before it will work. The firmware files are not publicly available. A package of the firmware which can be installed via pkg_add(1) is available: http://weongyo.org/project/upgt/upgt-firmware-184.108.40.206.tar.gz
HARDWAREThe upgt driver supports USB 2.0 Conexant/Intersil PrismGT series wireless adapters based on the GW3887 chipset, among them: · Belkin F5D7050 (version 1000) · Cohiba Proto Board · D-Link DWL-G120 Cohiba · FSC Connect2Air E-5400 USB D1700 · Gigaset USB Adapter 54 · Inventel UR045G · Netgear WG111v1 (rev2) · SMC EZ ConnectG SMC2862W-G · Sagem XG703A · Spinnaker DUT · Spinnaker Proto Board
EXAMPLESJoin an existing BSS network (i.e., connect to an access point): ifconfig wlan create wlandev upgt0 inet 192.168.0.20 \ netmask 0xffffff00 Join a specific BSS network with network name “my_net”: ifconfig wlan create wlandev upgt0 ssid my_net up Join a specific BSS network with 64-bit WEP encryption: ifconfig wlan create wlandev upgt0 ssid my_net \ wepmode on wepkey 0x1234567890 weptxkey 1 up
SEE ALSOarp(4), netintro(4), usb(4), wlan(4), ifconfig(8)
HISTORYThe upgt driver first appeared in OpenBSD 4.3.
AUTHORSThe upgt driver was written by Marcus Glocker <@openbsd.org>. The hardware specification was reverse engineered by the people at http://www.prism54.org.
CAVEATSThe upgt driver just supports the USB 2.0 devices (GW3887 chipset) but not the USB 1.0 devices containing the NET2280, ISL3880, and ISL3886 chipsets. Some further efforts would be necessary to add USB 1.0 support to the driver.
|This manual||Reference||Other manuals|
|refer to||arp(4freebsd) | ifconfig(8) | netintro(4freebsd) | upgt(4freebsd) | usb(4freebsd) | wlan(4freebsd)|