IPW(4FREEBSD) - Linux man page online | Special files
Intel PRO/Wireless 2100 IEEE 802.11 driver.
October 15, 2015
IPW(4) BSD Kernel Interfaces Manual IPW(4)
BSD October 15, 2015 BSD
NAMEipw — Intel PRO/Wireless 2100 IEEE 802.11 driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configura‐ tion file: device ipw device ipwfw device pci device wlan device firmware Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): if_ipw_load="YES" In both cases, place the following line in loader.conf(5) to acknowledge the firmware license (see below): legal.intel_ipw.license_ack=1
DESCRIPTIONThe ipw driver provides support for the Intel PRO/Wireless 2100 MiniPCI network adapter. ipw supports station, adhoc, and monitor mode operation. Only one virtual interface may be configured at any time. For more information on configuring this device, see ifconfig(8). This driver requires the firmware built with the ipwfw module to work. For the loaded firmware to be enabled for use the license at /usr/share/doc/legal/intel_ipw.LICENSE must be agreed by adding the following line to loader.conf(5): legal.intel_ipw.license_ack=1
FILES/usr/share/doc/legal/intel_ipw.LICENSE ipw firmware license
EXAMPLESJoin an existing BSS network (i.e., connect to an access point): ifconfig wlan create wlandev ipw0 inet 192.168.0.20 \ netmask 0xffffff00 Join a specific BSS network with network name “my_net”: ifconfig wlan create wlandev ipw0 ssid my_net up Join a specific BSS network with 64-bit WEP encryption: ifconfig wlan create wlandev ipw0 ssid my_net \ wepmode on wepkey 0x1234567890 weptxkey 1 up Join a specific BSS network with 128-bit WEP encryption: ifconfig wlan create wlandev ipw0 wlanmode adhoc ssid my_net \ wepmode on wepkey 0x01020304050607080910111213 weptxkey 1
DIAGNOSTICSipw%d: device timeout The driver will reset the hardware. This should not happen. ipw%d: firmware error The onboard microcontroller crashes for some reason. The driver will reset the hardware. This should not happen. ipw%d: timeout waiting for firmware initialization to complete The onboard microcontroller failed to initialize in time. This should not happen. ipw%d: could not load firmware image '%s' The driver failed to load the firmware image using the firmware(9) subsystem. Verify the ipwfw(4) firmware module is installed and the license agreement loader(8) tunable has been set. ipw%d: could not load microcode An attempt to upload the microcode image to the onboard microcontroller failed. This should not happen. ipw%d: could not load firmware An attempt to upload the firmware image to the onboard microcontroller failed. This should not happen.
SEE ALSOipwfw(4), pci(4), wlan(4), wlan_ccmp(4), wlan_tkip(4), wlan_wep(4), ifconfig(8), wpa_supplicant(8)
AUTHORSThe original ipw driver was written by Damien Bergamini <@free.fr>.
|This manual||Reference||Other manuals|
|ipw(4freebsd)||referred by||ALTQ(4freebsd) | altq(4freebsd) | if_ipw(4freebsd) | ipwfw(4freebsd) | wlan(4freebsd)|
|refer to||firmware(9freebsd) | ifconfig(8) | ipwfw(4freebsd) | pci(4freebsd) | wlan(4freebsd) | wlan_ccmp(4freebsd) | wlan_tkip(4freebsd) | wlan_wep(4freebsd) | wpa_supplicant(8)|