ISER(4FREEBSD) - Linux man page online | Special files
ISCSI Extensions for RDMA (iSER) driver.
June 6, 2016
ISER(4) BSD Kernel Interfaces Manual ISER(4)
BSD June 6, 2016 BSD
NAMEiser — iSCSI Extensions for RDMA (iSER) driver
SYNOPSISTo compile this driver into the kernel, place the following line in the kernel configuration file: device iser Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): iser_load="YES"
DESCRIPTIONThe iser (iSCSI Extensions for RDMA) initiator driver extends the iSCSI protocol to RDMA. It permits data to be transferred directly into and out of SCSI buffers without intermediate data copies. iSER uses the RDMA protocol suite to supply higher bandwidth for block storage transfers (zero copy behavior). To that fact, it eliminates the TCP/IP processing overhead while preserving the compatibility with iSCSI protocol. The initiator is the iSCSI/iSER client, which connects to an iSCSI/iSER target, providing local access to a remote block device. The userland component is provided by iscsid(8) and both the kernel and userland are configured using iscsictl(8).
SYSCTL VARIABLESThe following variables are available as both sysctl(8) variables and loader(8) tunables: kern.iser.debug Verbosity level for log messages from the iser driver. Set to 0 to disable logging or 1 to warn about potential problems. Larger values enable info and debugging out‐ put. Defaults to 0.
SEE ALSOiscsi(4), iscsi.conf(5), iscsictl(8), iscsid(8)
HISTORYThe iser subsystem first appeared in FreeBSD 11.0.
AUTHORSThe iser subsystem was developed by Max Gurtovoy <@mellanox.com> and Sagi Grimberg <@mellanox.com> under sponsorship from Mellanox Technologies.
|This manual||Reference||Other manuals|
|refer to||iscsi(4freebsd) | iscsid(8) | sysctl(8)|