MLX5EN(4FREEBSD) - Linux man page online | Special files
Mellanox ConnectX-4 and ConnectX-4 LX based 100Gb, 50Gb, 40Gb, 25Gb and 10Gb Ethernet adapter driver.
December 3, 2015
MLX5EN(4) BSD Kernel Interfaces Manual MLX5EN(4)
BSD December 3, 2015 BSD
NAMEmlx5en — Mellanox ConnectX-4 and ConnectX-4 LX based 100Gb, 50Gb, 40Gb, 25Gb and 10Gb Ether‐ net adapter driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configura‐ tion file: options COMPAT_LINUXKPI device mlx5 device mlx5en To load the driver as a module at run-time, run the following command as root: kldload mlx5en To load the driver as a module at boot time, place the following lines in loader.conf(5): mlx5en_load="YES"
DESCRIPTIONThe mlx5en driver provides support for PCI Express Ethernet adapters based on ConnectX-4 and ConnectX-4 LX. The driver supports Jumbo Frames, Transmit/Receive checksum offload, TCP segmentation offload (TSO), Large Receive Offload (LRO), HW Large Receive Offload (HW LRO), VLAN tag insertion/extraction, VLAN checksum offload, VLAN TSO, and Receive Side Steering (RSS). The network interface is named mce. For further hardware information and questions related to hardware requirements, see http://www.mellanox.com/. For more information on configuring this device, see ifconfig(8).
HARDWAREThe mlx5en driver supports 100Gb, 50Gb, 40Gb, 25Gb and 10Gb Ethernet adapters. ConnectX-4 supports:10/20/25/40/50/56/100Gb/s speeds. ConnectX-4 LX supports:10/25/40/50Gb/s speeds (and reduced power consumption) : · Mellanox MCX455A-ECAT · Mellanox MCX456A-ECAT · Mellanox MCX415A-CCAT · Mellanox MCX416A-CCAT · Mellanox MCX455A-FCAT · Mellanox MCX456A-FCAT · Mellanox MCX415A-BCAT · Mellanox MCX416A-BCAT · Mellanox MCX4131A-GCAT · Mellanox MCX4131A-BCAT · Mellanox MCX4121A-ACAT · Mellanox MCX4111A-ACAT · Mellanox MCX4121A-XCAT · Mellanox MCX4111A-XCAT
SUPPORTFor general information and support, go to the Mellanox support website at: http://www.mellanox.com/. If an issue is identified with this driver with a supported adapter, email all the specific information related to the issue to ⟨@mellanox.com⟩.
HISTORYThe mlx5en device driver first appeared in FreeBSD 11.0.
AUTHORSThe mlx5en driver was written by Mellanox Technologies <@mellanox.com>.
|This manual||Reference||Other manuals|