MVS(4FREEBSD) - Linux man page online | Special files
Marvell Serial ATA Host Controller driver.
March 23, 2015
MVS(4) BSD Kernel Interfaces Manual MVS(4)
BSD March 23, 2015 BSD
NAMEmvs — Marvell Serial ATA Host Controller driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configura‐ tion file: device pci device scbus device mvs Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): mvs_load="YES" The following tunables are settable from the loader(8): hint.mvs.X.msi controls Message Signaled Interrupts (MSI) usage by the specified controller. hint.mvs.X.ccc controls Command Completion Coalescing (CCC) usage by the specified controller. Non-zero value enables CCC and defines maximum time (in us), request can wait for interrupt. CCC reduces number of context switches on systems with many parallel requests, but it can decrease disk performance on some workloads due to additional command latency. hint.mvs.X.cccc defines number of completed commands for CCC, which trigger interrupt without waiting for specified coalescing timeout. hint.mvsch.X.pm_level controls SATA interface Power Management for the specified channel, allowing some power to be saved at the cost of additional command latency. Possible values: 0 interface Power Management is disabled (default); 1 device is allowed to initiate PM state change, host is passive; 4 driver initiates PARTIAL PM state transition 1ms after port becomes idle; 5 driver initiates SLUMBER PM state transition 125ms after port becomes idle. Note that interface Power Management is not compatible with device presence detection. A manual bus reset is needed on device hot-plug. hint.mvsch.X.sata_rev setting to nonzero value limits maximum SATA revision (speed). Values 1, 2 and 3 are respectively 1.5, 3 and 6Gbps.
DESCRIPTIONThis driver provides the CAM(4) subsystem with native access to the SATA ports of several generations (Gen-I/II/IIe) of Marvell SATA controllers. Each SATA port found is represented to CAM as a separate bus with one target, or, if HBA supports Port Multipliers (Gen-II/IIe), 16 targets. Most of the bus-management details are handled by the SATA-specific transport of CAM. Connected ATA disks are handled by the ATA protocol disk peripheral driver ada(4). ATAPI devices are handled by the SCSI protocol peripheral drivers cd(4), da(4), sa(4), etc. Driver features include support for Serial ATA and ATAPI devices, Port Multipliers (includ‐ ing FIS-based switching, when supported), hardware command queues (up to 31 command per port), Native Command Queuing, SATA interface Power Management, device hot-plug and Message Signaled Interrupts.
HARDWAREThe mvs driver supports the following controllers: Gen-I (SATA 1.5Gbps): · 88SX5040 · 88SX5041 · 88SX5080 · 88SX5081 Gen-II (SATA 3Gbps, NCQ, PMP): · 88SX6040 · 88SX6041 (including Adaptec 1420SA) · 88SX6080 · 88SX6081 Gen-IIe (SATA 3Gbps, NCQ, PMP with FBS): · 88SX6042 · 88SX7042 (including Adaptec 1430SA) · 88F5182 SoC · 88F6281 SoC · MV78100 SoC Note, that this hardware supports command queueing and FIS-based switching only for ATA DMA commands. ATAPI and non-DMA ATA commands executed one by one for each port.
SEE ALSOada(4), ata(4), cam(4), cd(4), da(4), sa(4)
HISTORYThe mvs driver first appeared in FreeBSD 8.1.
AUTHORSAlexander Motin <@FreeBSD.org>
|This manual||Reference||Other manuals|
|mvs(4freebsd)||referred by||ada(4freebsd) | ata(4freebsd) | hptrr(4freebsd) | rr232x(4freebsd)|
|refer to||ada(4freebsd) | ata(4freebsd) | cd(4freebsd) | da(4freebsd) | sa(4freebsd)|