HPTRR(4FREEBSD) - man page online | special files
HighPoint RocketRAID device driver.
June 6, 2012
HPTRR(4) BSD Kernel Interfaces Manual HPTRR(4)
NAMEhptrr — HighPoint RocketRAID device driver
SYNOPSISTo compile this driver into the kernel, place the following line in your kernel configura‐ tion file: device hptrr device scbus device da Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): hptrr_load="YES" The following tunables are settable from the loader: hw.hptrr.attach_generic set to 1 to permit driver attach to chips with generic Marvell (non-HighPoint) PCI identifi‐ cation. These chips are also supported by ata(4) and mvs(4). Some vendors are using same chips, but without providing RAID BIOS.
DESCRIPTIONThe hptrr driver provides support for HighPoint's RocketRAID based RAID controllers. These devices support SATA/ATA disk drives and provide RAID0 (striping), RAID1 (mirroring), and RAID5 functionality.
HARDWAREThe hptrr driver supports the following RAID controllers: · RocketRAID 172x series · RocketRAID 174x series · RocketRAID 2210 · RocketRAID 222x series · RocketRAID 2240 · RocketRAID 230x series · RocketRAID 231x series · RocketRAID 232x series · RocketRAID 2340 · RocketRAID 2522
NOTESThe hptrr driver only works on the i386 and amd64 platforms as it requires a binary blob object from the manufacturer which they only supply for these platforms. The hptrr driver does not work on i386 with pae(4) enabled. This driver does not support the RR182x series controller. See the hptmv(4) manual page for details on support. This driver supersedes the older rr232x driver.
SEE ALSOata(4), cam(4), hptmv(4), mvs(4), loader(8)
HISTORYThe hptrr device driver first appeared in FreeBSD 6.3.
AUTHORSThe hptrr device driver was written by HighPoint Technologies, Inc., and ported to FreeBSD by Scott Long. This manual page was written by David E. O'Brien.
BSD June 6, 2012 BSD
BUGSThe hptrr driver does not support manipulating the RAID from the OS, RAIDs need to be set up from the on-board BIOS.
|This manual||Reference||Other manuals|
|refer to||ata(4freebsd) | hptmv(4freebsd) | mvs(4freebsd)|