OTUS(4FREEBSD) - Linux man page online | Special files
Atheros AR9170 USB IEEE 802.11a/b/g/n wireless network device.
OTUS(4) BSD Kernel Interfaces Manual OTUS(4)
BSD September 25, 2015 BSD
NAMEotus — Atheros AR9170 USB IEEE 802.11a/b/g/n wireless network device
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configura‐ tion file: device ehci device uhci device ohci device usb device otus device wlan Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): if_otus_load="YES"
DESCRIPTIONThe otus driver supports USB 2.0 wireless network devices based on the Atheros AR9170 chipset. The Atheros AR9170 is a draft-802.11n adapter that uses an external radio to operate in either 2.4GHz only or 2.4GHz and 5GHz. The AR9101 radio supports 1T1R operation in 2GHz only. The AR9102 radio supports 2T2R operation in 2GHz only. The AR9104 radio supports 2T2R operation both 2GHz and 5GHz. These are the modes the otus driver can operate in: BSS mode Also known as infrastructure mode, this is used when associating with an access point, through which all traffic passes. This mode is the default. The otus driver can be configured to use Wired Equivalent Privacy (WEP) or Wi-Fi Protected Access (WPA-PSK and WPA2-PSK). WPA is the de facto encryption standard for wireless net‐ works. It is strongly recommended that WEP not be used as the sole mechanism to secure wireless communication, due to serious weaknesses in it. The otus driver can be configured at runtime with ifconfig(8).
FILESThe driver needs at least version 1.0 of the following firmware files, which is loaded when an interface is attached: /boot/kernel/otusfw-init.ko /boot/kernel/otusfw-main.ko
HARDWAREThe otus driver provices support for Atheros AR9170 USB IEEE 802.11b/g/n wireless network adapters, including: 3Com 3CRUSBN275 Arcadyan WN7512 CACE AirPcap Nx D-Link DWA-130 rev D1 D-Link DWA-160 rev A1 D-Link DWA-160 rev A2 IO-Data WN-GDN/US2 NEC Aterm WL300NU-G Netgear WNDA3100 Netgear WN111 v2 Planex GW-US300 SMC Networks SMCWUSB-N2 TP-Link TL-WN821N v1, v2 Ubiquiti SR71 USB Unex DNUA-81 Z-Com UB81 Z-Com UB82 ZyXEL NWD-271N
EXAMPLESJoin an existing BSS network (i.e., connect to an access point): ifconfig wlan create wlandev otus0 inet 192.168.0.20 \ netmask 0xffffff00 Join a specific BSS network with network name “my_net”: ifconfig wlan create wlandev otus0 ssid my_net up Join a specific BSS network with 64-bit WEP encryption: ifconfig wlan create wlandev otus0 ssid my_net \ wepmode on wepkey 0x1234567890 weptxkey 1 up
DIAGNOSTICS%s: failed load firmware of file otusfw-main For some reason, the driver was unable to read the microcode file from the filesystem. The file might be missing or corrupted.
SEE ALSOintro(1), netintro(4), otusfw(4), usb(4), wlan(4), arp(8), hostapd(8), ifconfig(8), wpa_supplicant(8)
HISTORYThe otus driver first appeared in OpenBSD 4.6.
AUTHORSThe otus driver was written by Damien Bergamini <@openbsd.org> and ported by Adrian Chadd <@freebsd.org>.
CAVEATSThe otus driver only supports 802.11a/b/g operations. 802.11 operation is not supported at this time.
|This manual||Reference||Other manuals|
|otus(4freebsd)||referred by||if_otus(4freebsd) | otusfw(4freebsd) | wlan(4freebsd)|
|refer to||arp(8) | hostapd(8) | ifconfig(8) | intro(1) | netintro(4freebsd) | otusfw(4freebsd) | usb(4freebsd) | wlan(4freebsd) | wpa_supplicant(8)|