PT(4FREEBSD) - Linux man page online | Special files
SCSI processor type driver.
March 2, 1995
PT(4) BSD Kernel Interfaces Manual PT(4)
BSD March 2, 1995 BSD
NAMEpt — SCSI processor type driver
DESCRIPTIONThe pt driver provides support for a SCSI processor type device. These are usually scanners and other devices using the SCSI link as a communication interface with device specific com‐ mands embedded in the data stream. A SCSI adapter must be separately configured into the system before this driver can be used. This device supports read(2) and write(2), and the ioctl(2) calls described below.
IOCTLSThe following ioctl(2) calls are supported by the pt driver. They are defined in the header file <sys/ptio.h>. PTIOCGETTIMEOUT This ioctl allows userland applications to fetch the current pt driver read and write timeout. The value returned is in seconds. PTIOCSETTIMEOUT This ioctl allows userland applications to set the current pt driver read and write timeouts. The value should be in seconds.
FILES/dev/ptN the Nth processor device.
HISTORYThe pt driver appeared in FreeBSD 2.1.
|This manual||Reference||Other manuals|
|pt(4freebsd)||referred by||CAM(4freebsd) | cam(4freebsd) | scbus(4freebsd) | SCSI(4freebsd) | scsi(4freebsd)|
|refer to||ioctl(2) | read(2) | write(2)|