RTWN(4FREEBSD) - Linux manual page online | Special files
Realtek RTL8188CE PCIe IEEE 802.11b/g/n wireless network device.
RTWN(4) BSD Kernel Interfaces Manual RTWN(4)
BSD October 28, 2015 BSD
NAMErtwn — Realtek RTL8188CE PCIe IEEE 802.11b/g/n wireless network device
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configura‐ tion file: device rtwn device rtwnfw device wlan device firmware Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): if_rtwn_load="YES" After you have read the license in /usr/share/doc/legal/realtek.LICENSE you will want to add the following lines to loader.conf(5): legal.realtek.license_ack=1 rtwn-rtl8192cfwU_load="YES" rtwn-rtl8192cfwU_B_load="YES"
DESCRIPTIONThe rtwn driver supports PCIe wireless network devices based on the Realtek RTL8188CE chipset. The RTL8188CE is a highly integrated 802.11n adapter that combines a MAC, a 1T1R capable baseband and an RF in a single chip. It operates in the 2GHz spectrum only. These are the modes the rtwn driver can operate in: BSS mode Also known as infrastructure mode, this is used when associating with an access point, through which all traffic passes. This mode is the default. monitor mode In this mode the driver is able to receive packets without associating with an access point. This disables the internal receive filter and enables the card to capture packets from networks which it wouldn't normally have access to, or to scan for access points. The rtwn driver can be configured to use Wired Equivalent Privacy (WEP) or Wi-Fi Protected Access (WPA-PSK and WPA2-PSK). WPA is the current encryption standard for wireless net‐ works. It is strongly recommended that WEP not be used as the sole mechanism to secure wireless communication, due to serious weaknesses in it. The rtwn driver can be configured at runtime with ifconfig(8).
FILESThe driver needs at least version 1.0 of the following firmware files, which are loaded when an interface is brought up: /boot/kernel/rtwn-rtl8192cfwU.ko /boot/kernel/rtwn-rtl8192cfwU_B.ko
EXAMPLESJoin an existing BSS network (i.e., connect to an access point): ifconfig wlan create wlandev rtwn0 inet 192.168.0.20 \ netmask 0xffffff00 Join a specific BSS network with network name “my_net”: ifconfig wlan create wlandev rtwn0 ssid my_net up Join a specific BSS network with 64-bit WEP encryption: ifconfig wlan create wlandev rtwn0 ssid my_net \ wepmode on wepkey 0x1234567890 weptxkey 1 up
DIAGNOSTICScould not read firmware %s For some reason, the driver was unable to read the microcode file from the filesystem. The file might be missing or corrupted. device timeout A frame dispatched to the hardware for transmission did not complete in time. The driver will reset the hardware. This should not happen.
SEE ALSOpci(4), rtwnfw(4), wlan(4), wlan_ccmp(4), wlan_tkip(4), wlan_wep(4), ifconfig(8), wpa_supplicant(8)
HISTORYThe rtwn driver first appeared in OpenBSD 5.8.
AUTHORSThe rtwn driver was written by Stefan Sperling <@openbsd.org> and ported by Kevin Lo <@freebsd.org>. It was based on the urtwn(4) driver written by Damien Bergamini <@free.fr>.
CAVEATSThe rtwn driver does not support any of the 802.11n capabilities offered by the adapters. Additional work is required in ieee80211(9) before those features can be supported.
|This manual||Reference||Other manuals|
|refer to||ieee80211(9freebsd) | ifconfig(8) | pci(4freebsd) | rtwnfw(4freebsd) | urtwn(4freebsd) | wlan(4freebsd) | wlan_ccmp(4freebsd) | wlan_tkip(4freebsd) | wlan_wep(4freebsd) | wpa_supplicant(8)|