RUE(4FREEBSD) - Linux man page online | Special files
RealTek RTL8150 USB to Fast Ethernet controller driver.
November 24, 2015
RUE(4) BSD Kernel Interfaces Manual RUE(4)
BSD November 24, 2015 BSD
NAMErue — RealTek RTL8150 USB to Fast Ethernet controller driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configura‐ tion file: device uhci device ohci device usb device miibus device uether device rue Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): if_rue_load="YES"
DESCRIPTIONThe rue driver provides support for USB Ethernet adapters based on the RealTek RTL8150 USB to Fast Ethernet controller chip. The RTL8150 contains an integrated Fast Ethernet MAC, which supports both 10 and 100Mbps speeds in either full or half duplex. Although designed to interface with 100Mbps periph‐ eral, the existing USB standard specifies a maximum transfer speed of 12Mbps. Users should therefore not expect to actually achieve 100Mbps speeds with this device. The rue driver supports the following media types: autoselect Enable auto selection of the media type and options. The user can manually override the auto selected mode by adding media options to the /etc/rc.conf file. 10baseT/UTP Set 10Mbps operation. The mediaopt option can also be used to select either full-duplex or half-duplex modes. 100baseTX Set 100Mbps (Fast Ethernet) operation. The mediaopt option can also be used to select either full-duplex or half-duplex modes. The rue driver supports the following media options: full-duplex Force full duplex operation. half-duplex Force half duplex operation. For more information on configuring this device, see ifconfig(8).
HARDWAREThe rue driver supports RealTek RTL8150 based USB Ethernet adapters including: · Buffalo (Melco Inc.) LUA-KTX · Green House GH-USB100B · LinkSys USB100M · Billionton 10/100 FastEthernet USBKR2
DIAGNOSTICSrue%d: watchdog timeout A packet was queued for transmission and a transmit command was issued, however the device failed to acknowledge the transmission before a timeout expired. rue%d: rx list init failed The driver failed to allocate an mbuf for the transmitter ring. rue%d: no memory for rx list The driver failed to allocate an mbuf for the receiver ring.
SEE ALSOarp(4), miibus(4), netintro(4), ng_ether(4), ifconfig(8) RealTek RTL8150 data sheet, http://pdf.seekdatasheet.com/2008714/200807142333305235.pdf.
HISTORYThe rue device driver first appeared in FreeBSD 5.1.
AUTHORSThe rue driver was written by Shunsuke Akiyama <@FreeBSD.org>.
|This manual||Reference||Other manuals|
|rue(4freebsd)||referred by||if_rue(4freebsd) | miibus(4freebsd) | usb(4freebsd)|
|refer to||arp(4freebsd) | ifconfig(8) | miibus(4freebsd) | netintro(4freebsd) | ng_ether(4freebsd)|