SBP(4FREEBSD) - Linux man page online | Special files
Serial Bus Protocol 2 (SBP-2) Mass Storage Devices driver.
February 8, 2012
SBP(4) BSD Kernel Interfaces Manual SBP(4)
BSD February 8, 2012 BSD
NAMEsbp — Serial Bus Protocol 2 (SBP-2) Mass Storage Devices driver
SYNOPSISkldload firewire kldload cam kldload sbp or device sbp device firewire device scbus device da device cd device pass
DESCRIPTIONThe sbp driver provides support for SBP-2 devices that attach to the FireWire (IEEE 1394) port. It should work with SBP-2 devices which the CAM layer supports, for example, HDDs, CDROM drives and DVD drives. Some users familiar with umass(4) might wonder why the device is not detached at the CAM layer when the device is unplugged. It is detached only if the device has not been plugged again during several bus resets. This is for preventing to detach an active file system even when the device cannot be probed correctly for some reason after a bus reset or when the device is temporary disconnected because the user changes the bus topology. If you want to force to detach the device, run “fwcontrol -r” several times or set hw.firewire.hold_count=0 by sysctl(8). Some (broken) HDDs do not work well with tagged queuing. If you have problems with such drives, try “camcontrol [device id] tags -N 1” to disable tagged queuing.
SEE ALSOcam(4), firewire(4), camcontrol(8), fwcontrol(8), kldload(8), sysctl(8)
AUTHORSThe sbp driver was written by Katsushi Kobayashi and Hidetoshi Shimokawa. This manual page was written by Katsushi Kobayashi.
|This manual||Reference||Other manuals|
|sbp(4freebsd)||referred by||firewire(4freebsd) | fwohci(4freebsd) | ieee1394(4freebsd)|
|refer to||firewire(4freebsd) | sysctl(8) | umass(4freebsd)|