IEEE1394(4FREEBSD) - Linux man page online | Special files
IEEE1394 High-performance Serial Bus.
May 11, 2012
FIREWIRE(4) BSD Kernel Interfaces Manual FIREWIRE(4)
BSD May 11, 2012 BSD
NAMEfirewire — IEEE1394 High-performance Serial Bus
SYNOPSISTo compile this driver into the kernel, place the following line in your kernel configura‐ tion file: device firewire Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): firewire_load="YES"
DESCRIPTIONFreeBSD provides machine-independent bus support and raw drivers for firewire interfaces. The firewire driver consists of two layers: the controller and the bus layer. The con‐ troller attaches to a physical bus (like pci(4)). The firewire bus attaches to the con‐ troller. Additional drivers can be attached to the bus. Up to 63 devices, including the host itself, can be attached to a firewire bus. The root node is dynamically assigned with a PHY device function. Also, the other firewire bus spe‐ cific parameters, e.g., node ID, cycle master, isochronous resource manager and bus manager, are dynamically assigned, after bus reset is initiated. On the firewire bus, every device is identified by an EUI 64 address. Debugging over the firewire interace is possible with the dcons(4) driver. Please see http://wiki.freebsd.org/DebugWithDcons for details on how to setup debugging with firewire.
SEE ALSOdcons(4), fwe(4), fwip(4), fwohci(4), pci(4), sbp(4), eui64(5), fwcontrol(8), kldload(8), sysctl(8)
HISTORYThe firewire driver first appeared in FreeBSD 5.0.
AUTHORSThe firewire driver was written by Katsushi Kobayashi and Hidetoshi Shimokawa for the FreeBSD project.
BUGSSee fwohci(4) for security notes.
|This manual||Reference||Other manuals|
|refer to||dcons(4freebsd) | firewire(4freebsd) | fwe(4freebsd) | fwip(4freebsd) | fwohci(4freebsd) | pci(4freebsd) | sbp(4freebsd) | sysctl(8)|