UATH(4FREEBSD) - Linux manual page online | Special files
Atheros USB IEEE 802.11a/b/g wireless network device.
UATH(4) BSD Kernel Interfaces Manual UATH(4)
BSD April 7, 2009 BSD
NAMEuath — Atheros USB IEEE 802.11a/b/g wireless network device
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configura‐ tion file: device ehci device uhci device ohci device usb device uath device wlan Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): if_uath_load="YES"
DESCRIPTIONThe uath driver supports USB 2.0 wireless network devices based on Atheros Communications fifth generation AR5005UG and AR5005UX chipsets. The AR5005UG chipset is made of an AR5523 multiprotocol MAC/baseband processor and an AR2112 Radio-on-a-Chip that can operate between 2300 and 2500 MHz (802.11b/g). The AR5005UX chipset is made of an AR5523 multiprotocol MAC/baseband processor and an AR5112 dual band Radio-on-a-Chip that can operate between 2300 and 2500 MHz (802.11b/g) or 4900 and 5850 MHz (802.11a). The AR5005UG and AR5005UX chipsets both have an integrated 32-bit MIPS R4000-class processor that runs a firmware and manages, among other things, the automatic control of the transmit rate and the calibration of the radio. uath supports station, and monitor mode operation. Only one virtual interface may be con‐ figured at any time. For more information on configuring this device, see ifconfig(8).
FIRMWAREuath requires firmware that is downloaded to the device. This is normally done by the uathload(8) utility that is launched by devd(8) when the device is inserted. uathload includes the firmware in the binary program. This firmware is licensed for general use and is included in the base system.
HARDWAREThe uath driver should work with the following adapters: Adapter Chipset Compex WLU108AG AR5005UX Compex WLU108G AR5005UG D-Link DWL-G132 AR5005UG IODATA WN-G54/US AR5005UG MELCO WLI-U2-KAMG54 AR5005UX Netgear WG111T AR5005UG Netgear WG111U AR5005UX Netgear WPN111 AR5005UG Olitec 000544 AR5005UG PLANET WDL-U357 AR5005UX Siemens Gigaset 108 AR5005UG SMC SMCWUSBT-G AR5005UG SMC SMCWUSBT-G2 AR5005UG SparkLAN WL-785A AR5005UX TP-Link TL-WN620G AR5005UG TRENDware International TEW-444UB AR5005UG TRENDware International TEW-504UB AR5005UX Unex Technology UR054ag AR5005UX ZyXEL XtremeMIMO M-202 AR5005UX An up to date list can be found at http://customerproducts.atheros.com/customerproducts/default.asp.
EXAMPLESJoin an existing BSS network (i.e., connect to an access point): ifconfig wlan create wlandev uath0 inet 192.168.0.20 \ netmask 0xffffff00 Join a specific BSS network with network name “my_net”: ifconfig wlan create wlandev uath0 ssid my_net up Join a specific BSS network with 64-bit WEP encryption: ifconfig wlan create wlandev uath0 ssid my_net \ wepmode on wepkey 0x1234567890 weptxkey 1 up Join a specific BSS network with 128-bit WEP encryption: ifconfig wlan create wlandev uath0 wlanmode adhoc ssid my_net \ wepmode on wepkey 0x01020304050607080910111213 weptxkey 1
DIAGNOSTICSuath%d: could not send command (error=%s) An attempt to send a command to the firmware failed. uath%d: timeout waiting for command reply A read command was sent to the firmware but the firmware failed to reply in time. uath%d: device timeout A frame dispatched to the hardware for transmission did not complete in time. The driver will reset the hardware. This should not happen.
SEE ALSOnetintro(4), usb(4), wlan(4), wlan_ccmp(4), wlan_tkip(4), wlan_wep(4), devd(8), ifconfig(8), uathload(8), wpa_supplicant(8)
HISTORYThe uath driver first appeared in OpenBSD 4.0.
AUTHORSThe uath driver was written by Weongyo Jeong <@FreeBSD.org> and Sam Leffler <@FreeBSD.org>. It is distantly related to a driver written by Damien Bergamini <@openbsd.org>.
CAVEATSAtheros proprietary 108 Mbps mode (aka Super AG mode) is not supported. Dual-band adapters are presently not working; to workaround, restriction operation to 2.4GHz channels.
|This manual||Reference||Other manuals|
|uath(4freebsd)||referred by||if_uath(4freebsd) | wlan(4freebsd)|
|refer to||ifconfig(8) | netintro(4freebsd) | usb(4freebsd) | wlan(4freebsd) | wlan_ccmp(4freebsd) | wlan_tkip(4freebsd) | wlan_wep(4freebsd) | wpa_supplicant(8)|