UFM(4FREEBSD) - Linux man page online | Special files
USB driver for Cypress Semiconductor FM Radio.
November 22, 2006
UFM(4) BSD Kernel Interfaces Manual UFM(4)
BSD November 22, 2006 BSD
NAMEufm — USB driver for Cypress Semiconductor FM Radio
SYNOPSISTo compile this driver into the kernel, place the following line in your kernel configura‐ tion file: device ufm Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): ufm_load="YES"
DESCRIPTIONThe ufm driver provides support for the D-Link/GEMTEK FM tuner. The USB interface chip is the common Cypress 63001, and the tuner is a Philips TEA5757 radio chip that uses a serial interface to set the tuner parameters. This design is used in the D-Link DSB-R100 USB Radio. The ufm device must be configured in the kernel, along with usb(4) and one of the uhci(4) or ohci(4) controllers. Subsequently, the /dev/ufm0 device can be used by userland applications.
FILES/dev/ufm0 blocking device node
SEE ALSOohci(4), uhci(4), usb(4)
AUTHORSThe ufm driver was written by M. Warner Losh <@FreeBSD.org> for FreeBSD.
|This manual||Reference||Other manuals|
|refer to||ohci(4freebsd) | uhci(4freebsd) | usb(4freebsd)|