UMS(4FREEBSD) - Linux man page online | Special files
USB mouse driver.
November 27, 2006
UMS(4) BSD Kernel Interfaces Manual UMS(4)
BSD November 27, 2006 BSD
NAMEums — USB mouse driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configura‐ tion file: device ums device uhci device ohci device usb Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): ums_load="YES"
DESCRIPTIONThe ums driver provides support for mice that attach to the USB port. Supported are mice with any number of buttons and mice with a wheel. The /dev/ums0 device presents the mouse as a sysmouse or mousesystems type device. See moused(8) for an explanation of these mouse types.
FILES/dev/ums0 blocking device node
EXAMPLESUse the first USB mouse on the system as your console mouse: moused -p /dev/ums0 -t auto To be able to use the USB mouse under X, change the "Pointer" section in xorg.conf to the following: Device /dev/ums0 Protocol Auto If you want to be able to use the mouse in both virtual consoles as well as in X change it to: Device /dev/sysmouse Protocol Auto
SEE ALSOohci(4), sysmouse(4), uhci(4), usb(4), xorg.conf(5) (ports/x11/xorg), moused(8)
AUTHORSThe ums driver was written by Lennart Augustsson <@cs.chalmers.se> for NetBSD and was adopted for FreeBSD by MAEKAWA Masahide <@rr.iij4u.or.jp>. This manual page was written by Nick Hibma <@FreeBSD.org> with input from Kazutaka YOKOTA <@zodiac.mech.utsunomiya-u.ac.jp>.
|This manual||Reference||Other manuals|
|ums(4freebsd)||referred by||mouse(4freebsd) | usb(4freebsd)|
|refer to||ohci(4freebsd) | sysmouse(4freebsd) | uhci(4freebsd) | usb(4freebsd) | xorg.conf(5)|