VIAPM(4FREEBSD) - Linux man page online | Special files
VIA chipsets Power Management controller driver.
April 20, 2002
VIAPM(4) BSD Kernel Interfaces Manual VIAPM(4)
BSD April 20, 2002 BSD
NAMEviapm — VIA chipsets Power Management controller driver
SYNOPSISdevice iicbb device iicbus device iicsmb device smbus device smb device viapm
DESCRIPTIONThis driver provides access to the VIA chipset Power Management Unit family. They are VT82C586B, VT82C596A, VT82C596B, VT82C686A and VT8233. The embedded controller of the VIA chipset may give you access to the monitoring facilities of your mainboard. The 586B support is made by software whereas other controllers support the SMBus protocol by hardware. See smb(4) for writing user code to fetch voltages, temperature and so on from the monitoring chip of your mainboard.
SEE ALSOiicbb(4), iicbus(4), iicsmb(4), smb(4), smbus(4)
HISTORYThe viapm manual page first appeared in FreeBSD 4.5.
AUTHORSThis manual page was written by Nicolas Souchu <@FreeBSD.org>.
BUGSOnly polling mode is supported.
|This manual||Reference||Other manuals|
|refer to||iicbb(4freebsd) | iicbus(4freebsd) | iicsmb(4freebsd) | smb(4freebsd) | smbus(4freebsd)|