VIAWD(4FREEBSD) - Linux man page online | Special files
Device driver for VIA south bridge watchdog timer.
December 7, 2011
VIAWD(4) BSD Kernel Interfaces Manual VIAWD(4)
BSD December 7, 2011 BSD
NAMEviawd — device driver for VIA south bridge watchdog timer
SYNOPSISTo compile this driver into the kernel, place the following line in your kernel configura‐ tion file: device viawd Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): viawd_load="YES"
DESCRIPTIONThe viawd driver provides watchdog(4) support for the watchdog interrupt timer present on VIA south bridge chipset (VT8251, CX700, VX800, VX855, VX900). The VIA south bridge have a built-in watchdog timer, which can be enabled and disabled by user's program and set between 1 to 1023 seconds. The viawd driver when unloaded with running watchdog will reschedule the watchdog to 5 min‐ utes.
SEE ALSOwatchdog(4), watchdog(8), watchdogd(8), watchdog(9)
HISTORYThe viawd driver first appeared in FreeBSD 10.0.
AUTHORSThe viawd driver and this manual page were written by Fabien Thomas <@FreeBSD.org>.
|This manual||Reference||Other manuals|
|refer to||watchdog(4freebsd) | watchdog(8) | watchdog(9freebsd)|