VX - reference manual online
3Com EtherLink III / Fast EtherLink III (3c59x) Ethernet driver.
July 16, 2005
VX(4) BSD/i386 Kernel Interfaces Manual VX(4)
NAME vx — 3Com EtherLink III / Fast EtherLink III (3c59x) Ethernet driver SYNOPSIS To compile this driver into the kernel, place the following line in your kernel configura‐ tion file: device vx Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): if_vx_load="YES" DESCRIPTION The vx driver provides support for the 3Com “Vortex” chipset. The medium selection can be influenced by the following link flags to the ifconfig(8) com‐ mand: link0 Use the AUI port. link1 Use the BNC port. link2 Use the UTP port. HARDWARE The vx driver supports the following cards: · 3Com 3c590 EtherLink III PCI · 3Com 3c592 EtherLink III EISA · 3Com 3c595 Fast EtherLink III PCI in 10 Mbps mode · 3Com 3c597 Fast EtherLink III EISA in 10 Mbps mode DIAGNOSTICS vx%d: not configured; kernel is built for only %d devices. There are not enough devices in the kernel configuration file for the number of adapters present in the system. Add devices to the configuration file, rebuild the kernel, and reboot. All other diagnostics indicate either a hardware problem or a bug in the driver. SEE ALSO arp(4), netintro(4), ng_ether(4), ifconfig(8) HISTORY The vx device driver first appeared in FreeBSD 2.1. It was derived from the ep driver, from which it inherits most of its limitations. CAVEATS Some early-revision 3c590 cards are defective and suffer from many receive overruns, which cause lost packets. The author has attempted to implement a test for it based on the infor‐ mation supplied by 3Com, but the test resulted mostly in spurious warnings. The performance of this driver is somewhat limited by the fact that it uses only polled-mode I/O and does not make use of the bus-mastering capability of the cards. BUGS The vx driver is known not to reset the adapter correctly following a warm boot on some sys‐ tems. The vx driver has not been exhaustively tested with all the models of cards that it claims to support.BSD July 16, 2005 BSD
|This manual||Reference||Other manuals|
|vx(4freebsd)||referred by||ep(4freebsd) | if_sn(4freebsd) | sn(4freebsd)|
|refer to||arp(4freebsd) | ifconfig(8) | netintro(4freebsd) | ng_ether(4freebsd)|