WBWD(4FREEBSD) - Linux man page online | Special files
Device driver for Winbond/Nuvoton Super I/O chips watchdog timer.
March 24, 2016
WBWD(4) BSD Kernel Interfaces Manual WBWD(4)
BSD March 24, 2016 BSD
NAMEwbwd — device driver for Winbond/Nuvoton Super I/O chips watchdog timer
SYNOPSISTo compile this driver into the kernel, place the following line in your kernel configura‐ tion file: device wbwd Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): wbwd_load="YES"
DESCRIPTIONThe wbwd driver provides watchdog(4) support for the watchdog interrupt timer present on at least the following Super I/O chips: · Winbond 83627HF/F/HG/G · Winbond 83627S · Winbond 83697HF · Winbond 83697UG · Winbond 83637HF · Winbond 83627THF · Winbond 83687THF · Winbond 83627EHF · Winbond 83627DHG · Winbond 83627UHG · Winbond 83667HG · Winbond 83627DHG-P · Winbond 83667HG-B · Nuvoton NCT6775 · Nuvoton NCT6776 · Nuvoton NCT6102 · Nuvoton NCT6779 · Nuvoton NCT6791 · Nuvoton NCT6792 Driver may be forced to attach to unknown chips by adding to /boot/device.hints: hint.wbwd.0.at="isa"
SYSCTL VARIABLESThe wbwd driver provides the following options as sysctl(8) variables. dev.wbwd.0.timeout_override This variable allows to program the timer to a value independent on the one provided by the watchdog(4) framework while still relying on the regular updates from e.g. watchdogd(8). This is particularly useful if your system provides multiple watch‐ dogs and you want them to fire in a special sequence to trigger an NMI after a shorter period than the reset timeout for example. The value set must not be lower than the sleep time of watchdogd(8). A value of 0 disables this feature and the timeout value provided by watchdog(4) will be used. dev.wbwd.0.debug_verbose If set this sysctl will tell the driver to log its current state before and after the timer reset on each invocation from watchdog(9) to the kernel message buffer for debugging. dev.wbwd.0.debug This read-only value gives the state of some registers on last update. The wbwd driver also provides further sysctl options that are hidden by default. See the source code for more information.
SEE ALSOwatchdog(4), device.hints(5), watchdog(8), watchdogd(8), watchdog(9)
HISTORYThe wbwd driver first appeared in FreeBSD 10.0.
AUTHORSThis manual page was written by Bjoern A. Zeeb <@FreeBSD.org>.
|This manual||Reference||Other manuals|
|refer to||sysctl(8) | watchdog(4freebsd) | watchdog(8) | watchdog(9freebsd)|