XPT(4FREEBSD) - Linux man page online | Special files
CAM transport layer interface.
October 10, 1998
XPT(4) BSD Kernel Interfaces Manual XPT(4)
BSD October 10, 1998 BSD
NAMExpt — CAM transport layer interface
DESCRIPTIONThe xpt driver provides a way for userland applications to issue certain CAM CCBs to the kernel. Since the xpt driver allows direct access to the CAM subsystem, system administrators should exercise caution when granting access to this driver. If used improperly, this driver can allow userland applications to crash a machine or cause data loss.
KERNEL CONFIGURATIONThere is no kernel configuration required for the xpt driver. It is enabled when SCSI sup‐ port is enabled in the kernel. There is one instance of the xpt driver per CAM transport layer instance. Since there is currently only one CAM transport layer, there will only be one instance of this driver.
IOCTLSCAMIOCOMMAND This ioctl takes certain kinds of CAM CCBs and passes them through to the CAM transport layer for action. Only the following CCB types are supported: XPT_SCAN_BUS XPT_RESET_BUS XPT_SCAN_LUN XPT_ENG_INQ XPT_ENG_EXEC XPT_DEBUG XPT_DEV_MATCH XPT_PATH_INQ The above CCBs are the only ones supported since it makes more sense to send them through a generic passthrough device rather than a passthrough device tied to a particular underlying SCSI device. CAMGETPASSTHRU This ioctl takes an XPT_GDEVLIST CCB, and returns the passthrough device corresponding to the device in question.
FILES/dev/xpt0 Character device node for the xpt driver.
SEE ALSOcam(3), cam_cdbparse(3), pass(4), camcontrol(8)
HISTORYThe CAM transport layer driver first appeared in FreeBSD 3.0.
AUTHORSKenneth Merry <@FreeBSD.org>
|This manual||Reference||Other manuals|
|xpt(4freebsd)||referred by||CAM(4freebsd) | cam(4freebsd) | ciss(4freebsd) | ida(4freebsd) | iir(4freebsd) | pass(4freebsd) | scbus(4freebsd) | SCSI(4freebsd) | scsi(4freebsd)|