ACCF_DATA(9FREEBSD) - Linux manual page online | System kernel interfaces
Buffer incoming connections until data arrives.
November 15, 2000
ACCF_DATA(9) BSD Kernel Developer's Manual ACCF_DATA(9)
BSD November 15, 2000 BSD
NAMEaccf_data — buffer incoming connections until data arrives
SYNOPSISoptions INET options ACCEPT_FILTER_DATA kldload accf_data
DESCRIPTIONThis is a filter to be placed on a socket that will be using accept() to receive incoming connections. It prevents the application from receiving the connected descriptor via accept() until data arrives on the connection. The ACCEPT_FILTER_DATA kernel option is also a module that can be enabled at runtime via kldload(8) if the INET option has been compiled into the kernel.
EXAMPLESAssuming ACCEPT_FILTER_DATA has been included in the kernel config file or the accf_data module has been loaded, this will enable the data accept filter on the socket sok. struct accept_filter_arg afa; bzero(&afa, sizeof(afa)); strcpy(afa.af_name, "dataready"); setsockopt(sok, SOL_SOCKET, SO_ACCEPTFILTER, &afa, sizeof(afa));
SEE ALSOsetsockopt(2), accept_filter(9), accf_dns(9), accf_http(9)
HISTORYThe accept filter mechanism and the accf_data filter were introduced in FreeBSD 4.0.
AUTHORSThis manual page and the filter were written by Alfred Perlstein.
|This manual||Reference||Other manuals|
|accf_data(9freebsd)||referred by||accept_filt_add(9freebsd) | accept_filt_del(9freebsd) | accept_filt_generic_mod_event(9freebsd) | accept_filt_get(9freebsd) | accept_filter(9freebsd) | accf_dns(9freebsd)|
|refer to||accept_filter(9freebsd) | accf_dns(9freebsd) | accf_http(9freebsd) | getsockopt(2)|