ACCF_HTTP(9FREEBSD) - Linux man page online | System kernel interfaces
Buffer incoming connections until a certain complete HTTP requests arrive.
November 15, 2000
ACCF_HTTP(9) BSD Kernel Developer's Manual ACCF_HTTP(9)
BSD November 15, 2000 BSD
NAMEaccf_http — buffer incoming connections until a certain complete HTTP requests arrive
SYNOPSISoptions INET options ACCEPT_FILTER_HTTP kldload accf_http
DESCRIPTIONThis is a filter to be placed on a socket that will be using accept() to receive incoming HTTP connections. It prevents the application from receiving the connected descriptor via accept() until either a full HTTP/1.0 or HTTP/1.1 HEAD or GET request has been buffered by the kernel. If something other than a HTTP/1.0 or HTTP/1.1 HEAD or GET request is received the kernel will allow the application to receive the connection descriptor via accept(). The utility of accf_http is such that a server will not have to context switch several times before performing the initial parsing of the request. This effectively reduces the amount of required CPU utilization to handle incoming requests by keeping active processes in pre‐ forking servers such as Apache low and reducing the size of the file descriptor set that needs to be managed by interfaces such as select(), poll() or kevent() based servers. The accf_http kernel option is also a module that can be enabled at runtime via kldload(8) if the INET option has been compiled into the kernel.
EXAMPLESAssuming ACCEPT_FILTER_HTTP has been included in the kernel config file or the accf_http module has been loaded, this will enable the http accept filter on the socket sok. struct accept_filter_arg afa; bzero(&afa, sizeof(afa)); strcpy(afa.af_name, "httpready"); setsockopt(sok, SOL_SOCKET, SO_ACCEPTFILTER, &afa, sizeof(afa));
SEE ALSOsetsockopt(2), accept_filter(9)
HISTORYThe accept filter mechanism and the accf_http filter were introduced in FreeBSD 4.0.
AUTHORSThis manual page and the filter were written by Alfred Perlstein.
|This manual||Reference||Other manuals|
|accf_http(9freebsd)||referred by||accept_filt_add(9freebsd) | accept_filt_del(9freebsd) | accept_filt_generic_mod_event(9freebsd) | accept_filt_get(9freebsd) | accept_filter(9freebsd) | accf_data(9freebsd) | accf_dns(9freebsd)|
|refer to||accept_filter(9freebsd) | getsockopt(2)|