ACCF_DNS(9FREEBSD) - Linux man page online | System kernel interfaces
Buffer incoming DNS requests until the whole first request is present.
July 16, 2008
ACCF_DNS(9) BSD Kernel Developer's Manual ACCF_DNS(9)
BSD July 16, 2008 BSD
NAMEaccf_dns — buffer incoming DNS requests until the whole first request is present
SYNOPSISoptions INET options ACCEPT_FILTER_DNS kldload accf_dns
DESCRIPTIONThis is a filter to be placed on a socket that will be using accept() to receive incoming connections. It prevents the application from receiving the connected descriptor via accept() until a whole DNS request is available on the socket. It does this by reading the first two bytes of the request, to determine its size, and waiting until the required amount of data is available to be read. The ACCEPT_FILTER_DNS kernel option is also a module that can be enabled at runtime via kldload(8) if the INET option has been compiled into the kernel.
EXAMPLESIf the accf_dns module is available in the kernel, the following code will enable the DNS accept filter on a socket sok. struct accept_filter_arg afa; bzero(&afa, sizeof(afa)); strcpy(afa.af_name, "dnsready"); setsockopt(sok, SOL_SOCKET, SO_ACCEPTFILTER, &afa, sizeof(afa));
SEE ALSOsetsockopt(2), accept_filter(9), accf_data(9), accf_http(9)
HISTORYThe accept filter mechanism was introduced in FreeBSD 4.0.
AUTHORSThis manual page and the filter were written by David Malone.
|This manual||Reference||Other manuals|
|accf_dns(9freebsd)||referred by||accept_filt_add(9freebsd) | accept_filt_del(9freebsd) | accept_filt_generic_mod_event(9freebsd) | accept_filt_get(9freebsd) | accept_filter(9freebsd) | accf_data(9freebsd)|
|refer to||accept_filter(9freebsd) | accf_data(9freebsd) | accf_http(9freebsd) | getsockopt(2)|