ACPI_ASUS(4FREEBSD) - Linux man page online | Special files
Asus Laptop Extras.
February 8, 2010
ACPI_ASUS(4) BSD Kernel Interfaces Manual ACPI_ASUS(4)
BSD February 8, 2010 BSD
NAMEacpi_asus — Asus Laptop Extras
SYNOPSISTo compile this driver into the kernel, place the following line in your kernel configura‐ tion file: device acpi_asus Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): acpi_asus_load="YES"
DESCRIPTIONThe acpi_asus driver provides support for the extra ACPI-controlled gadgets, such as hotkeys and leds, found on recent Asus (and Medion) laptops. It allows one to use the sysctl(8) interface to manipulate the brightness of the LCD panel and the display output state. Hotkey events are passed to devd(8) for easy handling in userspace with the default configu‐ ration in /etc/devd/asus.conf. Currently, the following Asus laptops are fully supported: xxN A1x A2x A3N A4D A6VM D1x J1x L2B L2D L2E L3C L3D L3H L4E L4R L5x L8x M1A M2E M6N M6R S1x S2x V6V W5A Eee PC Additionally, acpi_asus also supports the Asus-compatible ATK0100 interface found in Samsung P30/P35 laptops.
SYSCTL VARIABLESThe following sysctls are currently implemented: hw.acpi.asus.lcd_brightness Makes the LCD backlight brighter or dimmer (higher values are brighter). hw.acpi.asus.lcd_backlight Turns the LCD backlight on or off. hw.acpi.asus.video_output Sets the active display to use according to a bitwise OR of the following: 0 No display 1 LCD 2 CRT 4 TV-Out Some models also support video switching via the generic acpi_video(4) driver. Most models do not, however. Defaults for these variables can be set in sysctl.conf(5), which is parsed at boot-time.
SEE ALSOacpi(4), acpi_asus_wmi(4), acpi_video(4), sysctl.conf(5), sysctl(8) The acpi4asus Project, http://sourceforge.net/projects/acpi4asus/.
HISTORYThe acpi_asus driver first appeared in FreeBSD 5.3.
AUTHORSThe acpi_asus driver and this manual page were written by Philip Paeps <@FreeBSD.org>. Inspiration came from the acpi4asus project started by Julien Lerouge which maintains a driver implementing this functionality in the Linux kernel.
|This manual||Reference||Other manuals|
|refer to||acpi(4freebsd) | acpi_asus_wmi(4freebsd) | acpi_video(4freebsd) | sysctl(8) | sysctl.conf(5)|