ACPI_ASUS_WMI(4FREEBSD) - Linux man page online | Special files
Asus Laptop WMI Extras.
July 2, 2012
ACPI_ASUS_WMI(4) BSD Kernel Interfaces Manual ACPI_ASUS_WMI(4)
BSD July 2, 2012 BSD
NAMEacpi_asus_wmi — Asus Laptop WMI Extras
SYNOPSISTo compile this driver into the kernel, place the following line in your kernel configura‐ tion file: device acpi_asus_wmi Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): acpi_asus_wmi_load="YES"
DESCRIPTIONThe acpi_asus_wmi driver provides support for the extra WMI-controlled gadgets, such as hotkeys and leds, found on Asus laptops. It allows one to use the sysctl(8) interface to manipulate the brightness of the LCD panel and keyboard backlight, power on/off different internal components, such as WiFi, Bluetooth, camera, cardreader, etc, read some sensors. Hotkey events are passed to devd(8) for easy handling in userspace with the default configu‐ ration in /etc/devd/asus.conf. Some hotkey events, such as keyboard backlight and touchpad control, are handled inside the driver.
SYSCTL VARIABLESThe following sysctls are currently implemented: dev.acpi_asus_wmi.0.handle_keys Specifies whether driver should handle some harwdare keys, such as keyboard back‐ light, internally. Number of other variables under the same sysctl branch are model-specific. Defaults for these variables can be set in sysctl.conf(5), which is parsed at boot-time.
SEE ALSOacpi(4), acpi_asus(4), acpi_video(4), sysctl.conf(5), devd(8), sysctl(8)
HISTORYThe acpi_asus_wmi driver first appeared in FreeBSD 10.0.
AUTHORSAlexander Motin <@FreeBSD.org>
|This manual||Reference||Other manuals|
|refer to||acpi(4freebsd) | acpi_asus(4freebsd) | acpi_video(4freebsd) | sysctl(8) | sysctl.conf(5)|