CFUMASS(4FREEBSD) - Linux man page online | Special files
USB device side support for Mass Storage Class Transport.
January 27, 2017
CFUMASS(4) BSD Kernel Interfaces Manual CFUMASS(4)
BSD January 27, 2017 BSD
NAMEcfumass — USB device side support for Mass Storage Class Transport
SYNOPSISThis driver can be compiled into the kernel by placing these lines in the kernel configura‐ tion file: device usb device usb_template device iscsi device ctl device cfumass The driver module can also be loaded at boot by adding this line to loader.conf(5): cfumass_load="YES"
DESCRIPTIONThe cfumass driver provides device side support for emulating an USB mass storage device compliant with the USB Mass Storage Class Bulk-Only (BBB) Transport specification, imple‐ mented as a ctl(4) frontend driver. To use cfumass: · cfumass(4) must be loaded as a module or compiled into the kernel. · The USB Mass Storage template must be chosen by setting the hw.usb.template sysctl to 0. · The USB OTG port must be working in USB device-side mode. This happens automatically upon connection to a USB host. · There must be a ctl LUN configured for the cfumass port. Upon loading, the driver creates a ctl(4) port named cfumass, presenting the first LUN mapped for that port - usually LUN 0 - to the USB host. See ctl.conf(5) and ctld(8) for details on configuring the LUN.
SYSCTL VARIABLESThese variables are available as both sysctl(8) variables and loader(8) tunables: hw.usb.cfumass.debug Verbosity level for log messages from the cfumass driver. Set to 0 to disable log‐ ging or 1 to warn about potential problems. Larger values enable debugging output. Defaults to 1. hw.usb.cfumass.ignore_stop Ignore START STOP UNIT SCSI commands with START and LOEJ bits cleared. Some initia‐ tors send that command to stop the target when the user attempts to gracefully eject the drive, but fail to start it when the drive is reconnected. Set to 0 to handle the command in a standards-compliant way, 1 to ignore it and log a warning, or 2 to ignore it silently. Defaults to 1. hw.usb.cfumass.max_lun Max LUN number to report to the initiator (USB host). Must be between 0 and 15. Some initiators incorrectly handle values larger than 0. Defaults to 0.
SEE ALSOctl(4), umass(4), usb(4), usb_template(4), ctl.conf(5), ctld(8)
HISTORYThe cfumass driver first appeared in FreeBSD 11.1.
AUTHORSThe cfumass driver was developed by Edward Tomasz Napierala <@FreeBSD.org> under spon‐ sorship from the FreeBSD Foundation.
|This manual||Reference||Other manuals|
|cfumass(4freebsd)||referred by||ctl(4freebsd) | umass(4freebsd) | usb_template(4freebsd) | usfs(4freebsd)|
|refer to||ctl(4freebsd) | sysctl(8) | umass(4freebsd) | usb(4freebsd) | usb_template(4freebsd)|