USFS(4FREEBSD) - Linux man page online | Special files
USB device side support for bulk only transport mass storage.
June 8, 2016
USFS(4) BSD Kernel Interfaces Manual USFS(4)
BSD June 8, 2016 BSD
NAMEusfs — USB device side support for bulk only transport mass storage
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configura‐ tion file: device usb device usfs Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): usfs_load="YES"
DESCRIPTIONThe usfs driver provides support for emulating an USB mass storage device when the USB stack is activated in USB device side mode (the usb_template(4) module is loaded and the hw.usb.template sysctl is set to 0). Upon attach the driver creates a RAM disk which can be read and written.
SEE ALSOcfumass(4), umass(4), usb(4), usb_template(4)
HISTORYThe usfs driver appeared in FreeBSD 8.
|This manual||Reference||Other manuals|
|refer to||cfumass(4freebsd) | umass(4freebsd) | usb(4freebsd) | usb_template(4freebsd)|