FAIR(7) - Linux man page online | Overview, conventions, and miscellany
Simple TCP load balancing service.
August 24, 2020
fair(7) BSD Miscellaneous Information Manual fair(7)
Debian GNU/Linux August 24, 2020 Debian GNU/Linux
NAMEfair — simple TCP load balancing service
DESCRIPTIONfair is a load balancer for TCP connections. It can be used to distribute incoming connec‐ tions for SMTP, HTTP or any other TCP service to multiple hosts, distributing the load as evenly as possible. fair consists of two daemons. The carrousel is the front-end; it keeps track of back-end hosts and their status, and forwards incoming connections to the back-ends in such a way that the load is distributed fairly. The transponder runs on the back-end hosts, it regis‐ ters with the carrousel and sends it status information. The TCP connections forwarded by the carrousel are not sent to the transponder daemons but are sent directly to the desired service running on the back-end host. Both daemons share a single configuration file.
EXAMPLESThe following example shows how to set up fair to service HTTP connections and to distribute them over back-ends in the 192.168.1.0/24 subnet. The configuration file /etc/fair.conf contains the following: WorkerService = http BalancerService = http AllowUDP = ^192.168.1.[0-9]+$ On www.example.com, the front-end server receiving the incoming HTTP connections, just run: carrousel On each of the back-ends run: transponder www.example.com
SEE ALSOcarrousel(8), transponder(8), fair.conf(5)
|This manual||Reference||Other manuals|
|fair(7)||referred by||carrousel(8) | transponder(8)|
|refer to||carrousel(8) | fair.conf(5) | transponder(8)|