FAIR.CONF(5) - Linux man page online | File formats
Configuration file for the carrousel and transponder daemons.
August 23, 2020
fair.conf(5) BSD File Formats Manual fair.conf(5)
Debian GNU/Linux August 23, 2020 Debian GNU/Linux
NAMEfair.conf — configuration file for the carrousel and transponder daemons
DESCRIPTIONDebug (bool, false) Runs the program in debug mode: it will not detach, it will print status updates very frequently, it will print extra diagnostic messages to stderr. DropPrivs (bool, true) The program will switch to a different uid/gid after obtaining root-only resources. See also the UserID and GroupID variables. WorkerService (string, smtp) * This is the service on which the worker nodes offer the service that is being bal‐ anced. Typically this is the service of another daemon, e.g. Postfix. The transpon‐ der daemon also uses this as the datagram source service for its status updates. BalancerService (string, smtp) * The stream service on which the carrousel daemon listens for incoming connections. These connections will be put through to one of the worker nodes. TransponderService (string, rlp) * The carrousel daemon listens on this service for status update datagrams from the transponders. See also the AllowUDP variable. PingInterval (time, 0.1 seconds) How often the transponder sends an update to each carrousel. So, if two carrousels are configured and the interval is 0.1 seconds, that transponder sends 20 packets every second. PingTimeout (time, 0.5 seconds) After this period has elapsed without receiving any status update packets from the transponder, this host is considered dead. IdleTimeout (time, 600.0 seconds) The connection is terminated if neither party has sent something for this many sec‐ onds. For SMTP connections this would have to be at least 600.0 seconds, see RFC 2821 section 22.214.171.124. ConnectTimeout (time, 1.0 seconds) When connecting to a worker node, abort after this many seconds have elapsed and no connection is established. ConnectAttempts (integer, 3) When putting through a connection fails, the carrousel will attempt to contact other worker nodes. It will give up after this many tries. BenchPeriod (time, 5.0 seconds) If a connection to a worker node fails it is excluded from new connections for this many seconds. TrailPeriod (time, 60.0 seconds) When a connection is finished, pretend it lasted this many seconds more for load calculation purposes. Hysteresis (integer, 0) Add an advantage to the last used worker node so that it gets selected in preference of others. MaxCapacity (integer, 100) When sending update packets, the capacity of the worker node measured in terms of concurrent connections. This number is adjusted for the current load average before sending it to the carrousel nodes. MaxBurst (integer, 65536) Ringbuffer size for load balancer nodes. MinBurst (integer, 1450) If fewer than this many bytes are available in the ring buffer, do not read anything but try to free up space first. LocalTCP (bool, yes) Only allow connections over the loopback interface. If this option is set to "no", connections will be accepted on any interface and on any address. AllowUDP (extended regexp, ^) Only datagram status packets that match this extended regular expression are accepted. All other datagram packets are logged and silently dropped. Once UDP packets are accepted from a certain source, they are never matched against this reg‐ exp again.
SEE ALSOcarrousel(8), transponder(8)
|This manual||Reference||Other manuals|
|fair.conf(5)||referred by||carrousel(8) | fair(7) | transponder(8)|
|refer to||carrousel(8) | transponder(8)|