NTPD(8) - Linux man page online | Administration and privileged commands
Network Time Protocol daemon.
NTPD(8) BSD System Manager's Manual NTPD(8)
BSD September 6, 2017 BSD
NAMEntpd — Network Time Protocol daemon
SYNOPSISntpd [-dnSsv] [-f file] [-p file]
DESCRIPTIONThe ntpd daemon synchronizes the local clock to one or more remote NTP servers or local timedelta sensors. ntpd can also act as an NTP server itself, redistributing the local time. It implements the Simple Network Time Protocol version 4, as described in RFC 5905, and the Network Time Protocol version 3, as described in RFC 1305. Time can also be fetched from TLS HTTPS servers to reduce the impact of unauthenticated NTP man-in-the-middle attacks, but support is currently not enabled on Debian due to missing LibreSSL's libtls implementation at this time. The options are as follows: -d Do not daemonize. If this option is specified, ntpd will run in the foreground and log to stderr. -f file Use file as the configuration file, instead of the default /etc/openntpd/ntpd.conf. -n Configtest mode. Only check the configuration file for validity. -p file Write pid to file -S Do not set the time immediately at startup. This is the default. -s Try to set the time immediately at startup, as opposed to slowly adjusting the clock. ntpd will stay in the foreground for up to 15 seconds waiting for one of the configured NTP servers to reply. -v This option allows ntpd to send DEBUG priority messages to syslog. ntpd uses the adjtime(2) system call to correct the local system time without causing time jumps. Adjustments of 32ms and greater are logged using syslog(3). The threshold value is chosen to avoid having local clock drift thrash the log files. Should ntpd be started with the -d or -v option, all calls to adjtime(2) will be logged. After the local clock is synchronized, ntpd adjusts the clock frequency using the adjfreq(2) system call to compensate for systematic drift. When ntpd starts up, it reads settings from its configuration file, typically ntpd.conf(5), and its initial clock drift from /var/lib/openntpd/ntpd.drift. Clock drift is periodically written to the drift file thereafter.
FILES/etc/openntpd/ntpd.conf Default configuration file. /var/lib/openntpd/ntpd.drift Drift file. /var/lib/openntpd/run/ntpd.sock Socket file for communication with ntpctl(8).
SEE ALSOdate(1), adjfreq(2), adjtime(2), ntpd.conf(5), ntpctl(8),
STANDARDSDavid L. Mills, Network Time Protocol (Version 3): Specification, Implementation and Analysis, RFC 1305, March 1992. David L. Mills, Jim Martin, Jack Burbank, and William Kasch, Network Time Protocol Version 4: Protocol and Algorithms Specification, RFC 5905, June 2010.
HISTORYThe ntpd program first appeared in OpenBSD 3.6.
|This manual||Reference||Other manuals|
|ntpd(8)||referred by||adjtimex(8) | adjtimexconfig(8) | ahcpd(8) | ffclock(4freebsd) | ntp-keygen(8) | ntp-wait(8) | ntp.conf(5) | ntp.keys(5) | ntp_adjtime(2freebsd) | ntp_gettime(2freebsd) | ntpctl(8) | ntpd.conf(5) | ntpdc(1) | ntpdig(1) | ntpwait(8) | rdate(8) | timemaster(8) | uart(4freebsd) | ucom(4freebsd)|
|refer to||adjtime(2freebsd) | date(1) | ntpctl(8) | ntpd.conf(5) | syslog(3)|