SIBA(4FREEBSD) - Linux man page online | Special files
Sonic Inc. Silicon Backplane driver.
June 3, 2016
SIBA(4) BSD Kernel Interfaces Manual SIBA(4)
BSD June 3, 2016 BSD
NAMEsiba — Sonic Inc. Silicon Backplane driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configura‐ tion file: device bhnd device siba Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): siba_load="YES"
DESCRIPTIONThe siba driver provides bhnd(4) support for devices based on the Sonic Inc. Silicon Back‐ plane, an interblock communications architecture found in earlier Broadcom Home Networking Division wireless chipsets and embedded systems. A common interconnect connects all of the Silicon Backplane's functional blocks. These functional blocks, known as cores, use the Open Core Protocol (OCP) interface to communicate with agents attached to the Silicon Backplane. Each core can have an initiator agent that passes read and write requests onto the system backplane and a target agent that returns responses to those requests. Not all cores con‐ tain both an initiator and a target agent. Initiator agents are present in cores that con‐ tain host interfaces (PCI, PCMCIA), embedded processors (MIPS), or DMA processors associated with communications cores.
SEE ALSObcma(4), bhnd(4)
HISTORYThe siba device driver first appeared in FreeBSD 8.0. The driver was rewritten for FreeBSD 11.0. to support the common Broadcom bhnd(4) bus interface.
AUTHORSThe siba driver was originally written by Bruce M. Simpson <@FreeBSD.org> and Weongyo Jeong <@FreeBSD.org>. The driver was rewritten for FreeBSD 11.0 by Landon Fuller <@FreeBSD.org>.
|This manual||Reference||Other manuals|
|siba(4freebsd)||referred by||bcma(4freebsd) | bhnd(4freebsd)|
|refer to||bcma(4freebsd) | bhnd(4freebsd)|