BHND(4FREEBSD) - Linux man page online | Special files
Broadcom Home Networking Division interconnect bus.
June 3, 2016
BHND(4) BSD Kernel Interfaces Manual BHND(4)
BSD June 3, 2016 BSD
NAMEbhnd — Broadcom Home Networking Division interconnect bus
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configura‐ tion file: device bhnd Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): bhnd_load="YES"
DESCRIPTIONThe bhnd driver provides a unified kernel bus interface to the on-chip interconnects used in Broadcom Home Networking Division (HND) devices. The Broadcom HND device family consists of SoCs (System On a Chip) and host-connected chipsets based on a common library of Broadcom IP cores connected via an internal hardware bus architecture. Drivers for these cores are implemented against the unified bhnd inter‐ face. The Sonic Inc. Silicon Backplane used in earlier HND devices is supported by the siba(4) BHND driver. The ARM AMBA-based interconnect used in later HND devices is supported by the bcma(4) BHND driver.
SEE ALSObhndb(4), bcma(4), siba(4)
HISTORYThe bhnd device driver first appeared in FreeBSD 11.0.
AUTHORSThe bhnd driver was written by Landon Fuller <@FreeBSD.org>.
|This manual||Reference||Other manuals|
|bhnd(4freebsd)||referred by||bcma(4freebsd) | bhndb(4freebsd) | siba(4freebsd)|
|refer to||bcma(4freebsd) | bhndb(4freebsd) | siba(4freebsd)|