UARK(4FREEBSD) - Linux man page online | Special files
Arkmicro Technologies ARK3116 based USB serial adapter.
UARK(4) BSD Kernel Interfaces Manual UARK(4)
BSD April 26, 2017 BSD
NAMEuark — Arkmicro Technologies ARK3116 based USB serial adapter
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configura‐ tion file: device usb device ucom device uark Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): uark_load="YES"
DESCRIPTIONThe uark driver supports Arkmicro Technologies ARK3116 based serial adapters.
HARDWAREThe uark driver supports the following adapters: · HL USB-RS232 · HugePine USB-UART · KQ-U8A Data Cable · Skymaster USB to RS232
FILES/dev/ttyU* for callin ports /dev/ttyU*.init /dev/ttyU*.lock corresponding callin initial-state and lock-state devices /dev/cuaU* for callout ports /dev/cuaU*.init /dev/cuaU*.lock corresponding callout initial-state and lock-state devices
SEE ALSOtty(4), ucom(4), usb(4)
HISTORYThe uark device driver first appeared in OpenBSD 4.0. The first FreeBSD release to include it was FreeBSD 7.0.
AUTHORSThe uark driver was written by Jonathan Gray <@openbsd.org>.
CAVEATSSetting hardware flow control is not currently supported. It is not yet known how to ask the hardware to send a break. Arkmicro Technologies do not reply to requests of documentation for their products.
|This manual||Reference||Other manuals|
|uark(4freebsd)||referred by||u3g(4freebsd) | u3gstub(4freebsd) | ucom(4freebsd)|
|refer to||tty(4) | ucom(4freebsd) | usb(4freebsd)|