UBTBCMFW(4FREEBSD) - Linux man page online | Special files
Firmware driver for Broadcom BCM2033 chip based Bluetooth USB devices.
November 22, 2006
UBTBCMFW(4) BSD Kernel Interfaces Manual UBTBCMFW(4)
BSD November 22, 2006 BSD
NAMEubtbcmfw — Firmware driver for Broadcom BCM2033 chip based Bluetooth USB devices
SYNOPSISTo compile this driver into the kernel, place the following line in your kernel configura‐ tion file: device ubtbcmfw Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): ubtbcmfw_load="YES"
DESCRIPTIONThe ubtbcmfw is a firmware driver for Broadcom BCM2033 chip based Bluetooth USB devices. It provides minimal access to the parts of the device required to download firmware. The ubtbcmfw driver creates three fixed endpoint device nodes. The control transfers can only happen on the control endpoint which is always endpoint 0. Control requests are issued by ioctl(2) calls. Only incoming transfers are supported on an interrupt endpoint. To perform I/O on an inter‐ rupt endpoint, read(2) should be used. All I/O operations on an interrupt endpoint are unbuffered. Interrupt endpoint is always endpoint 1. Only outgoing bulk transfers are supported on a bulk endpoint. To perform I/O on a bulk endpoint, write(2) should be used. All I/O operations on a bulk endpoint are unbuffered. Outgoing bulk endpoint is always endpoint 2. The control endpoint (endpoint 0) handles the following ioctl(2) calls: USB_GET_DEVICE_DESC (usb_device_descriptor_t) Return the device descriptor.
FILES/dev/ubtbcmfwN.EE Endpoint EE of device N.
SEE ALSOng_ubt(4), ugen(4), usb(4), bcmfw(8)
HISTORYThe ubtbcmfw driver was implemented in FreeBSD 5.0.
AUTHORSMaksim Yevmenkin <@yahoo.com>
BUGSMost likely. Please report if found.
|This manual||Reference||Other manuals|
|refer to||ioctl(2) | ng_ubt(4freebsd) | read(2) | ugen(4freebsd) | usb(4freebsd) | write(2)|