UCHCOM(4FREEBSD) - Linux man page online | Special files
WinChipHead CH341/CH340 serial adapter driver.
April 26, 2017
UCHCOM(4) BSD Kernel Interfaces Manual UCHCOM(4)
BSD April 26, 2017 BSD
NAMEuchcom — WinChipHead CH341/CH340 serial adapter driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configura‐ tion file: device usb device ucom device uchcom Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): uchcom_load="YES"
DESCRIPTIONThe uchcom driver provides support for the WinChipHead CH341/CH340 USB-to-RS-232 Bridge chip. The device is accessed through the ucom(4) driver which makes it behave like a tty(4).
HARDWAREThe uchcom driver supports the following adapters: · HL USB-RS232
FILES/dev/ttyU* for callin ports /dev/ttyU*.init /dev/ttyU*.lock corresponding callin initial-state and lock-state devices /dev/cuaU* for callout ports /dev/cuaU*.init /dev/cuaU*.lock corresponding callout initial-state and lock-state devices
SEE ALSOtty(4), ucom(4), usb(4)
HISTORYThe uchcom driver first appeared in NetBSD. The first FreeBSD release to include it was FreeBSD 8.0.
BUGSActually, this chip seems unable to drive other than 8 data bits and 1 stop bit line.
|This manual||Reference||Other manuals|
|refer to||tty(4) | ucom(4freebsd) | usb(4freebsd)|