UCYCOM(4FREEBSD) - Linux man page online | Special files
Device driver for Cypress CY7C63743 and CY7C64013 USB to RS232 bridges.
April 26, 2017
UCYCOM(4) BSD Kernel Interfaces Manual UCYCOM(4)
BSD April 26, 2017 BSD
NAMEucycom — device driver for Cypress CY7C63743 and CY7C64013 USB to RS232 bridges
SYNOPSISTo compile this driver into the kernel, place the following line in your kernel configura‐ tion file: device usb device ucom device ucycom Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): ucycom_load="YES"
DESCRIPTIONThe ucycom driver provides support for the Cypress CY7C63743 and CY7C64013 bridge chips. These chips were designed to provide a low-cost transition path to USB for existing RS232 devices, and have fairly limited capabilities. The ucycom driver behaves like a tty(4).
HARDWAREThe ucycom driver currently supports the following devices which incorporate Cypress USB to RS232 bridge chips: · DeLorme Earthmate USB GPS receiver
FILES/dev/ttyU* for callin ports /dev/ttyU*.init /dev/ttyU*.lock corresponding callin initial-state and lock-state devices /dev/cuaU* for callout ports /dev/cuaU*.init /dev/cuaU*.lock corresponding callout initial-state and lock-state devices
SEE ALSOtty(4), ucom(4), usb(4)
HISTORYThe ucycom driver first appeared in FreeBSD 5.3.
AUTHORSThe ucycom driver and this manual page were written by Dag-Erling Smørgrav <@FreeBSD.org>.
|This manual||Reference||Other manuals|
|refer to||tty(4) | ucom(4freebsd) | usb(4freebsd)|