UMCS(4FREEBSD) - Linux man page online | Special files
USB support for serial adapters based on the MCS7820 and MCS7840 chips.
April 26, 2017
UMCS(4) BSD Kernel Interfaces Manual UMCS(4)
BSD April 26, 2017 BSD
NAMEumcs — USB support for serial adapters based on the MCS7820 and MCS7840 chips
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configura‐ tion file: device usb device ucom device umcs Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): umcs_load="YES"
DESCRIPTIONThe umcs driver provides support for various multiport serial adapters based on the MosCom MCS7820 and MCS7840 chips. They are 2- or 4-port adapters with full-featured 16550-compati‐ ble UARTs and very flexible baud generators. Also, these chips support RS422/RS485 and IrDA operations. The device is accessed through the ucom(4) driver which makes it behave like a tty(4). Different ports on device are presented as sub-units, like /dev/ttyU0.1 and /dev/ttyU0.2.
HARDWAREThe umcs driver was tested on the following adapters: · ST Lab U-360 two-port serial USB adapter · ST Lab U-400 four-port serial USB adapter
FILES/dev/ttyU*.* for callin ports /dev/ttyU*.*.init /dev/ttyU*.*.lock corresponding callin initial-state and lock-state devices /dev/cuaU*.* for callout ports /dev/cuaU*.*.init /dev/cuaU*.*.lock corresponding callout initial-state and lock-state devices
SEE ALSOtty(4), ucom(4), usb(4)
HISTORYThe umcs driver appeared in ports since December of 2010.
AUTHORSThe umcs driver was written by Lev Serebryakov <@FreeBSD.org>.
BUGSThis driver doesn't support access to any fine tunes of chip, like RS522/RS485 mode, non- standard baudrates, etc.
|This manual||Reference||Other manuals|
|refer to||tty(4) | ucom(4freebsd) | usb(4freebsd)|