UVISOR(4FREEBSD) - Linux man page online | Special files
USB support for the PalmOS based PDAs.
April 26, 2017
UVISOR(4) BSD Kernel Interfaces Manual UVISOR(4)
BSD April 26, 2017 BSD
NAMEuvisor — USB support for the PalmOS based PDAs
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configura‐ tion file: device usb device ucom device uvisor Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): uvisor_load="YES"
DESCRIPTIONThe uvisor driver provides support for USB based PalmOS PDAs, like Handspring Visor, Palm Mxxx series, and Sony Clie. The device is accessed through the ucom(4) driver which makes it behave like a tty(4). The device has several ports for different purposes, each of them gets its own ucom(4) device. The attach message describes the purpose of each port. The usual Pilot tools can be used to access the attached device on the HotSync port.
HARDWAREThe uvisor driver supports the following devices: · Aceeca Mez1000 RDA · Handspring Treo · Handspring Treo 600 · Handspring Visor · Palm I705 · Palm M125 · Palm M130 · Palm M500 · Palm M505 · Palm M515 · Palm Tungsten T · Palm Tungsten Z · Palm Zire · Palm Zire 31 · Sony Clie 4.0 · Sony Clie 4.1 · Sony Clie 5.0 · Sony Clie PEG-S500C · Sony Clie NX60 · Sony Clie S360 · Sony Clie TJ37
FILES/dev/ttyU* for callin ports /dev/ttyU*.init /dev/ttyU*.lock corresponding callin initial-state and lock-state devices /dev/cuaU* for callout ports /dev/cuaU*.init /dev/cuaU*.lock corresponding callout initial-state and lock-state devices
SEE ALSOtty(4), ucom(4), usb(4)
HISTORYThe uvisor driver was adopted from NetBSD 1.5 in August 2002. This manual page was adopted from NetBSD by Tom Rhodes <@FreeBSD.org> at that time.
BUGSThe code to provide multiple ucom(4) instances has not yet been ported from NetBSD. It is unclear whether this driver works in its current state.
|This manual||Reference||Other manuals|
|refer to||tty(4) | ucom(4freebsd) | usb(4freebsd)|