CC_CDG(4FREEBSD) - Linux man page online | Special files
CDG Congestion Control Algorithm.
July 2, 2013
CC_CDG(4) BSD Kernel Interfaces Manual CC_CDG(4)
BSD July 2, 2013 BSD
NAMEcc_cdg — CDG Congestion Control Algorithm
DESCRIPTIONCAIA-Delay Gradient (CDG) is a hybrid congestion control algorithm which reacts to both packet loss and inferred queuing delay. It attempts to operate as a delay-based algorithm where possible, but utilises heuristics to detect loss-based TCP cross traffic and will com‐ pete effectively as required. CDG is therefore incrementally deployable and suitable for use on shared networks. During delay-based operation, CDG uses a delay-gradient based probabilistic backoff mecha‐ nism, and will also try to infer non congestion related packet losses and avoid backing off when they occur. During loss-based operation, CDG essentially reverts to cc_newreno(4)-like behaviour. CDG switches to loss-based operation when it detects that a configurable number of consecu‐ tive delay-based backoffs have had no measurable effect. It periodically attempts to return to delay-based operation, but will keep switching back to loss-based operation as required. MIB Variables The algorithm exposes the following variables in the net.inet.tcp.cc.cdg branch of the sysctl(3) MIB: version Current algorithm/implementation version number. beta_delay Delay-based window decrease factor as a percentage (on delay-based back‐ off, w = w * beta_delay / 100). Default is 70. beta_loss Loss-based window decrease factor as a percentage (on loss-based backoff, w = w * beta_loss / 100). Default is 50. exp_backoff_scale Scaling parameter for the probabilistic exponential backoff. Default is 2. smoothing_factor Number of samples used for moving average smoothing (0 means no smooth‐ ing). Default is 8. loss_compete_consec_cong Number of consecutive delay-gradient based congestion episodes which will trigger loss-based CC compatibility. Default is 5. loss_compete_hold_backoff Number of consecutive delay-gradient based congestion episodes to hold the window backoff for loss-based CC compatibility. Default is 5. alpha_inc If non-zero, this enables an experimental mode where CDG's window increase factor (alpha) is increased by 1 MSS every alpha_inc RTTs during congestion avoidance mode. (Setting alpha_inc to 1 results in the most aggressive growth of the window increase factor over time. Use higher alpha_inc values for slower growth.) Default is 0.
SEE ALSOcc_chd(4), cc_cubic(4), cc_hd(4), cc_htcp(4), cc_newreno(4), cc_vegas(4), h_ertt(4), mod_cc(4), tcp(4), khelp(9), mod_cc(9) D. A. Hayes and G. Armitage, "Revisiting TCP Congestion Control using Delay Gradients", Networking 2011 Proceedings, Part II, 328-341, May 2011. N. Khademi and G. Armitage, Minimising RTT across homogeneous 802.11 WLANs with CAIA Delay- Gradient TCP (v0.1), CAIA Technical Report 121113A, http://caia.swin.edu.au/reports/121113A/CAIA-TR-121113A.pdf, November 2012.
ACKNOWLEDGEMENTSDevelopment and testing of this software were made possible in part by grants from the Free‐ BSD Foundation and The Cisco University Research Program Fund, a corporate advised fund of Silicon Valley Community Foundation.
HISTORYThe cc_cdg congestion control module first appeared in FreeBSD 9.2. The module was first released in 2011 by David Hayes whilst working on the NewTCP research project at Swinburne University of Technology's Centre for Advanced Internet Architectures, Melbourne, Australia. More details are available at: http://caia.swin.edu.au/urp/newtcp/
AUTHORSThe cc_cdg congestion control module was written by David Hayes <@ieee.org>. This manual page was written by Lawrence Stewart <@FreeBSD.org> and Grenville Armitage <@swin.edu.au>.
BUGSThe underlying algorithm and parameter values are still a work in progress and may not be optimal for some network scenarios.
|This manual||Reference||Other manuals|
|cc_cdg(4freebsd)||referred by||CCV(9freebsd) | DECLARE_CC_MODULE(9freebsd) | mod_cc(4freebsd) | mod_cc(9freebsd)|
|refer to||cc_chd(4freebsd) | cc_cubic(4freebsd) | cc_hd(4freebsd) | cc_htcp(4freebsd) | cc_newreno(4freebsd) | cc_vegas(4freebsd) | h_ertt(4freebsd) | khelp(9freebsd) | mod_cc(4freebsd) | mod_cc(9freebsd) | sysctl(3freebsd) | tcp(4freebsd)|