CC_NEWRENO(4FREEBSD) - Linux man page online | Special files
NewReno Congestion Control Algorithm.
September 15, 2011
CC_NEWRENO(4) BSD Kernel Interfaces Manual CC_NEWRENO(4)
BSD September 15, 2011 BSD
NAMEcc_newreno — NewReno Congestion Control Algorithm
DESCRIPTIONThe NewReno congestion control algorithm is the default for TCP. Details about the algo‐ rithm can be found in RFC5681. MIB Variables There are currently no tunable MIB variables.
SEE ALSOcc_chd(4), cc_cubic(4), cc_hd(4), cc_htcp(4), cc_vegas(4), mod_cc(4), tcp(4), mod_cc(9)
ACKNOWLEDGEMENTSDevelopment and testing of this software were made possible in part by grants from the Free‐ BSD Foundation and Cisco University Research Program Fund at Community Foundation Silicon Valley.
HISTORYThe cc_newreno congestion control algorithm first appeared in its modular form in FreeBSD 9.0. The module was first released in 2007 by James Healy and Lawrence Stewart whilst working on the NewTCP research project at Swinburne University of Technology's Centre for Advanced Internet Architectures, Melbourne, Australia, which was made possible in part by a grant from the Cisco University Research Program Fund at Community Foundation Silicon Valley. More details are available at: http://caia.swin.edu.au/urp/newtcp/
AUTHORSThe cc_newreno congestion control module was written by James Healy <@deefa.com>, Lawrence Stewart <@FreeBSD.org> and David Hayes <@ieee.org>. This manual page was written by Lawrence Stewart <@FreeBSD.org>.
|This manual||Reference||Other manuals|
|cc_newreno(4freebsd)||referred by||cc_cdg(4freebsd) | cc_chd(4freebsd) | cc_cubic(4freebsd) | cc_dctcp(4freebsd) | cc_hd(4freebsd) | cc_htcp(4freebsd) | cc_vegas(4freebsd) | CCV(9freebsd) | DECLARE_CC_MODULE(9freebsd) | mod_cc(4freebsd) | mod_cc(9freebsd) | tcp(4freebsd)|
|refer to||cc_chd(4freebsd) | cc_cubic(4freebsd) | cc_hd(4freebsd) | cc_htcp(4freebsd) | cc_vegas(4freebsd) | mod_cc(4freebsd) | mod_cc(9freebsd) | tcp(4freebsd)|