MOD_CC(4FREEBSD) - man page online | special files
Modular congestion control.
September 15, 2011
MOD_CC(4) BSD Kernel Interfaces Manual MOD_CC(4)
NAME mod_cc — Modular congestion control DESCRIPTION The modular congestion control framework allows the TCP implementation to dynamically change the congestion control algorithm used by new and existing connections. Algorithms are iden‐ tified by a unique ascii(7) name. Algorithm modules can be compiled into the kernel or loaded as kernel modules using the kld(4) facility. The default algorithm is NewReno, and all connections use the default unless explicitly overridden using the TCP_CONGESTION socket option (see tcp(4) for details). The default can be changed using a sysctl(3) MIB variable detailed in the MIB Variables section below. MIB Variables The framework exposes the following variables in the net.inet.tcp.cc branch of the sysctl(3) MIB: available Read-only list of currently available congestion control algorithms by name. algorithm Returns the current default congestion control algorithm when read, and changes the default when set. When attempting to change the default algorithm, this variable should be set to one of the names listed by the net.inet.tcp.cc.available MIB variable. SEE ALSO cc_chd(4), cc_cubic(4), cc_hd(4), cc_htcp(4), cc_newreno(4), cc_vegas(4), tcp(4), mod_cc(9) ACKNOWLEDGEMENTS Development and testing of this software were made possible in part by grants from the Free‐ BSD Foundation and Cisco University Research Program Fund at Community Foundation Silicon Valley. HISTORY The mod_cc modular congestion control framework first appeared in FreeBSD 9.0. The framework was first released in 2007 by James Healy and Lawrence Stewart whilst working on the NewTCP research project at Swinburne University of Technology's Centre for Advanced Internet Architectures, Melbourne, Australia, which was made possible in part by a grant from the Cisco University Research Program Fund at Community Foundation Silicon Valley. More details are available at: http://caia.swin.edu.au/urp/newtcp/BSD September 15, 2011 BSD
|This manual||Reference||Other manuals|
|mod_cc(4freebsd)||referred by||cc_cdg(4freebsd) | cc_chd(4freebsd) | cc_cubic(4freebsd) | cc_hd(4freebsd) | cc_htcp(4freebsd) | cc_newreno(4freebsd) | cc_vegas(4freebsd) | h_ertt(4freebsd) | mod_cc(9freebsd) | tcp(4freebsd)|
|refer to||ascii(7) | cc_chd(4freebsd) | cc_cubic(4freebsd) | cc_hd(4freebsd) | cc_htcp(4freebsd) | cc_newreno(4freebsd) | cc_vegas(4freebsd) | kld(4freebsd) | mod_cc(9freebsd) | sysctl(3freebsd) | tcp(4freebsd)|